Squeaking under hood. - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-23-2010, 12:31 AM Thread Starter
Junior Member
 
lilyo95's Avatar
 
Join Date: Jun 2009
Posts: 19
 
Squeaking under hood.

My car has a squeaking noise coming from the belt system. I have changed the belt, the tensioner pulley, and the alternator was recently replaced. It's still has the chirping/squeak, does anyone know what this could be. It's the 4.3L L99.

95 Caprice/Impala Clone-95 Cadillac Fleetwood
Specializing in Kandies, Pearls, Graphics, Fiberglassing and minor collision repair.
lilyo95 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-23-2010, 12:42 AM
Senior Member
 
Join Date: Jul 2005
Location: Los Angeles
Posts: 3,409
 
Quote:
Originally Posted by lilyo95 View Post
My car has a squeaking noise coming from the belt system. I have changed the belt, the tensioner pulley, and the alternator was recently replaced. It's still has the chirping/squeak, does anyone know what this could be. It's the 4.3L L99.
Did you just change the tensioner pulley as stated or the tensioner? You need to change the tensioner.

Jim B.

'95 9c1, pcmperformance.com 93 tune, Dynomax Ultraflo catback, K & N box filter, LT4 KM, 160 stat, 3.08 Posi.
fbi9c1 is offline  
post #3 of 4 (permalink) Old 04-23-2010, 12:48 AM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 9,597
 
You could have a fluid leak which is landing on the belt, causing it to slip a little. I believe there is also an idler pulley on the bottom next to the pulley on the crank.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, custom fender skirts, stainless full moons, Recaros, Blazer console, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check http://www.impalassforum.com/vBullet...1#post11691762
Fred Kiehl is offline  
post #4 of 4 (permalink) Old 04-23-2010, 06:41 PM
Senior Member
 
Join Date: Jul 2006
Location: Little Rock, Arkansas
Posts: 629
 
Squeaking under hood.

Every time I had a belt squeak, it was solved with a GOODYEAR GATORBACK.
skill3 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome