LS Swap Basics - Page 82 - Chevy Impala SS Forum
 1Likes
 
LinkBack Thread Tools Display Modes
post #811 of 1244 (permalink) Old 01-07-2013, 03:26 PM
Senior Member
 
Join Date: Mar 2004
Location: greenville ohio
Posts: 161
 
Quote:
Originally Posted by dirtyharry View Post
Cpt shane is not building trans no more...for fi. Go on ls1tech.com a lot if info on there
yeah I know. got one of the last ones he built. I guess step one at this point is trying to decide which engine/trans options to go with.


jamey is offline  
Sponsored Links
Advertisement
 
post #812 of 1244 (permalink) Old 01-08-2013, 12:03 AM
Senior Member
 
jimmyjam's Avatar
 
Join Date: Sep 2011
Location: Clearwater, FL
Posts: 153
 
Garage
Quote:
Originally Posted by jamey View Post
so after reading for a few hours i'm not sure the direction to go. 94 caprice, decently built 4l60 from shane, wanting to swap in a FI 5.3/6.0 and potentially a 4l80 if needs be, for a goal of 500-600whp with either a roots blower or a rear mount turbo setup. looking for kind of a check list of parts, advise, to make a to do list lol. lots of planning and prep to do and kind of overwhelmed with where to start. thoughts? suggestions?
skip the rear mount turbo. where are you going to put it? if it ends up by the axle, screw it, waste of time, its going to lag like a mug. if you delete ABS there is a ton of room under the hood to do a front mount. otherwise a tvs 1900 will get you in the 500rwhp range or go 2300 and set your sights higher

1996 Impala SS - DCM - LS swap in progress...
2006 Trailblazer SS - 402ci LS2, RWD 4L80 swap
jimmyjam is offline  
post #813 of 1244 (permalink) Old 01-22-2013, 12:00 PM
Senior Member
 
Join Date: Jul 2006
Location: Mid west
Posts: 176
 
Send a message via AIM to fast lt1
Well i've starting looking for a motor and i've been researching some and i'm wondering if the 6sp Auto transmissions out of the Silverado 1500's will fit in the Impala's without major modification.
fast lt1 is offline  
post #814 of 1244 (permalink) Old 01-22-2013, 03:09 PM
Senior Member
 
SStreet King's Avatar
 
Join Date: Aug 2009
Location: Lakewood NJ
Posts: 973
 
Threw this little video together the other night.




1996 BBB Impala SS: SOLD
Heads/Cam LS3 500RWHP (Mustang dyno)
Built and Tuned by Tune Time Performance.

2012 CTS V:
10.24@137MPH - http://youtu.be/o9hapMTspEg
SStreet King is offline  
post #815 of 1244 (permalink) Old 01-23-2013, 08:31 AM
Senior Member
 
jimmyjam's Avatar
 
Join Date: Sep 2011
Location: Clearwater, FL
Posts: 153
 
Garage
thought i'd share a pic, haven't seen anyone run gen5 Camaro accessories

the stock alternator pulley is pretty large, replaced it with one off of a truck alt I had laying around. also had to massage the steering gear for clearance. and lastly, move the abs box over about 1" (note the mount on the gear box) to clear the ps pump





I have a question, what do people do about coupling radiator hoses? the only thing I could find locally are nylon couplers at home depot, do you think they will be ok at operating temp?


1996 Impala SS - DCM - LS swap in progress...
2006 Trailblazer SS - 402ci LS2, RWD 4L80 swap

Last edited by jimmyjam; 01-23-2013 at 08:35 AM.
jimmyjam is offline  
post #816 of 1244 (permalink) Old 01-23-2013, 11:04 AM Thread Starter
Senior Member
 
GA95DCMSS's Avatar
 
Join Date: Apr 2007
Location: Quantico, VA by way of ATL
Posts: 1,299
 
Send a message via Yahoo to GA95DCMSS
Jimmy, to couple the radiator hoses, I used an aluminum adapter from jagsthatrun. Mine has a port for the steam line, and a bleeder valve on it to assist with getting rid of air. I'll look and see what hose I used, as we are using the same water pump and PS pump setup. IIRC I just bought a new Lower hose for the Lt1 Impala SS and used it for the top connection.

You can see the adapter in the photo above the oil filter (in the radiator hose of course).
Attached Thumbnails
Click image for larger version

Name:	IMG_20110610_200126.jpg
Views:	201
Size:	197.3 KB
ID:	27426  

Quentin-1995 Impala SS-. New PB coming soon

Last edited by GA95DCMSS; 01-23-2013 at 11:13 AM.
GA95DCMSS is offline  
post #817 of 1244 (permalink) Old 01-24-2013, 06:58 PM
Junior Member
 
Join Date: Jan 2013
Posts: 2
 
NY State Inspection?

Excellent forumÖÖ.
I have learned so much, thank you.
Iíve read through a lot of posts and unless Iíve missed something, will the conversion pass a NY State Inspection?
Mac9955 is offline  
post #818 of 1244 (permalink) Old 01-24-2013, 09:29 PM
Senior Member
 
jimmyjam's Avatar
 
Join Date: Sep 2011
Location: Clearwater, FL
Posts: 153
 
Garage
Quote:
Originally Posted by GA95DCMSS View Post
Jimmy, to couple the radiator hoses, I used an aluminum adapter from jagsthatrun. Mine has a port for the steam line, and a bleeder valve on it to assist with getting rid of air. I'll look and see what hose I used, as we are using the same water pump and PS pump setup. IIRC I just bought a new Lower hose for the Lt1 Impala SS and used it for the top connection.

You can see the adapter in the photo above the oil filter (in the radiator hose of course).
do you mind feeding my curiosity? it seems like you've connected the steam line to the nipple on the coolant reservoir, using a T, is the other side of the T capped?

1996 Impala SS - DCM - LS swap in progress...
2006 Trailblazer SS - 402ci LS2, RWD 4L80 swap
jimmyjam is offline  
post #819 of 1244 (permalink) Old 01-25-2013, 05:07 PM Thread Starter
Senior Member
 
GA95DCMSS's Avatar
 
Join Date: Apr 2007
Location: Quantico, VA by way of ATL
Posts: 1,299
 
Send a message via Yahoo to GA95DCMSS
Quote:
Originally Posted by jimmyjam View Post
do you mind feeding my curiosity? it seems like you've connected the steam line to the nipple on the coolant reservoir, using a T, is the other side of the T capped?
There is no T in that photo, it was run straight to the coolant reservoir. I switched it to a T in the new setup as there isn't anywhere on my factory radiator to run it.

Quentin-1995 Impala SS-. New PB coming soon
GA95DCMSS is offline  
post #820 of 1244 (permalink) Old 01-25-2013, 08:31 PM
Senior Member
 
dirtyharry's Avatar
 
Join Date: Nov 2009
Location: Maryland PG
Posts: 237
 
Here my new setup
Attached Thumbnails
Click image for larger version

Name:	20130120_170601.jpg
Views:	230
Size:	195.4 KB
ID:	27486  

D.C INC........ Trigger Man
Got work? Got mods? Got LSX?
dirtyharry is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome