Opticrap - Chevy Impala SS Forum
LinkBack Thread Tools Display Modes
post #1 of 20 (permalink) Old 08-11-2010, 07:30 PM Thread Starter
Junior Member
jessecool's Avatar
Join Date: Aug 2010
Posts: 13

Hey everyone, I am new to this forum but a long time impala owner. I just encountered a problem with my 95 ss. Lately after my car warms up upon exceleration and stop at traffic lights my idle is unstable. Then this morning the car would not start. When i finaly got it started i was revving the car from the throttle body and it shocked my hand, then cut off and wouldn't start. I am assuming this is the optispark crapping out. Tonight i am going to change the opti and plugs and wires. Hopefully this is the problem
jessecool is offline  
Sponsored Links
post #2 of 20 (permalink) Old 08-11-2010, 09:39 PM
Senior Member
Join Date: Jul 2001
Location: Brooklyn
Posts: 515
doesnt sound like the opti to me? Keep researching those syptoms. Check the camaro boards and other LT1 related sites.

95 Impala SS, Stock LT1, RAISS Intake, F-body MAF, PCMPerformance tune, Try Y's headers, Clear Image stainless steal 2.5 pro street exhaust, air pump delete, no cats, LT4 knock module, Edge 2800 stall converter, Stage II trans rebuilt, 3:73 gears, posi trac, 9c1 front calipers, thicker Performance Friction Carbon Metallic pads, Pro slot rotors, ATE racing brake fluid, stealth brake bolt......
Ree SS is offline  
post #3 of 20 (permalink) Old 08-11-2010, 09:42 PM
Sophomore Member
Join Date: May 2003
Location: Huntsville, AL
Posts: 8,089
Send a message via AIM to sherlock9c1
Well, if you've never serviced the ignition system, how is it crap if it wears out? Go spend some time reading in here and you should find lots and lots of information that will help you.

"The unexamined life is not worth living." - Socrates
sherlock9c1 is offline  
post #4 of 20 (permalink) Old 08-11-2010, 09:56 PM
Senior Member
Dan Fahey's Avatar
Join Date: Jan 2001
Location: Germantown
Posts: 3,188
Our cars are old and things wear out.
Sounds like time for a thorough Ignition System Maintenance.

New Plug Wires, Coil Wire and Plugs.
Rebuild the ICM and Coil system
Buy and install a new ICM.
From Innovative Wiring get a new Opti Harness
Install a new Temp Sensor and harness.

Not really all that money..

Do all this before replacing the OPTI.
Dan Fahey is offline  
post #5 of 20 (permalink) Old 08-11-2010, 10:20 PM
Senior Member
Fred Kiehl's Avatar
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 9,514
I agree with the ignition wires...you got shocked...the only part that can give you that jolt is the ignition system on the high side of the coil. The rest of the car is 12 volts, and you can touch both poles of the battery with your fingers and not even feel it.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, custom fender skirts, stainless full moons, Recaros, Blazer console, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check http://www.impalassforum.com/vBullet...1#post11691762
Fred Kiehl is offline  
post #6 of 20 (permalink) Old 08-12-2010, 12:36 AM Thread Starter
Junior Member
jessecool's Avatar
Join Date: Aug 2010
Posts: 13
Thanks for the info..i checked the wires at nite,(no sparks,the plugs and wires are fairly new..everything is well maintained..but about a year ago i had the same symptons after i let my wife use the car during a rain storm and she said she had hit a large puddle of water..the next day the car was missing and runing like crap. So i googled my problem and everything pointed at the opti. I removed the vac vents at the bottom of the opti and blew air though them with my compressor and some water came out and presto..car was running good again..??? I was thinking about that coil-pack system.

1995 Impala ss
1972 Impala Sedan
2005 gsxr 750
1986 Buick GN
jessecool is offline  
post #7 of 20 (permalink) Old 08-12-2010, 03:02 AM
Senior Member
Gregg-O's Avatar
Join Date: Sep 2005
Location: Phoenix, AZ
Posts: 5,693
OPTI vent harness is how old? Getting shocked while touching the TB has nothing to do with the OPTI, you have another isue going on.

Taxes are not levied for the benefit of the taxed.

\'96 IMP SS BBB ,Stock, airbox is swiss cheese, K&N filter, Ultra Flows.
Gregg-O is offline  
post #8 of 20 (permalink) Old 08-13-2010, 04:59 PM Thread Starter
Junior Member
jessecool's Avatar
Join Date: Aug 2010
Posts: 13
Well,bad news today..went to my buddy's shop to check my car. I replaced the cap & rotor, new plugs, wires, and a new coil...still nothing. My mechanic says I'm getting plenty of spark, and when he disconnects the injectors and manually sprays starting fluid it will run, just that the injectors are dispensing fuel out out of order..He says the only thing left is the ECM?..timing is good,compression is good, injectors clean and good, fuel pump good....What do you guys think? And by the way about a year back my friend with a 96 ss, ran his car at the track and the same thing happend to him and he ended up parting his car out...????

1995 Impala ss
1972 Impala Sedan
2005 gsxr 750
1986 Buick GN
jessecool is offline  
post #9 of 20 (permalink) Old 08-13-2010, 05:18 PM
Senior Member
Join Date: Jul 2010
Posts: 192
Cool Sounds like she does not like you....

Any codes? Was it a 95 or 96? ECM could be the devil on this one, or maybe she just does not want it anymore. I would scan for codes, as far as getting "shocked" that almost seems like a ground issue.

96 Candy Coated Impala 20's, Kenwood double din dvd/nav,Two Rockford 12"s, 7" Alpine screens in the headrests, MSD ignition Coil, crate motor in 07', Jet MAF, tuned PCM, flowmaster exhaust,MSD 8.5 wires, K&N intake, and, and, and, and, you get the idea! Owned since 99 done it all three times.

97 Corvette C5 Bone Stock (Boyd Cottington Rims)

99 Chevy Suburban LT K1500 lowered w black 22"s ALL BLACK

95 DCM restoring (SOLD)

96 DGGM Impala SS Bone Stock (Hers)
Whyteowle is offline  
post #10 of 20 (permalink) Old 08-13-2010, 07:36 PM Thread Starter
Junior Member
jessecool's Avatar
Join Date: Aug 2010
Posts: 13
Its a 95 ECM..and if i'm mistaken i think the car reads OBD1 but has an OBD2 plug. Now if it is the ECM, will a 94 ECM the same lt1 work? I know that the 96 has front and rear o2's. And the 94-95's only had front o'2..so i think they should match..

1995 Impala ss
1972 Impala Sedan
2005 gsxr 750
1986 Buick GN
jessecool is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome