Turn Signal Stuck ?? - Chevy Impala SS Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 03-24-2012, 09:51 PM Thread Starter
Senior Member
 
Coolwazabi's Avatar
 
Join Date: Mar 2011
Location: Nashville
Posts: 158
 
Turn Signal Stuck ??

So I just got doing the hockey puck mod "which is breezy" and when it drive it around and suddenly my right turn signal is stuck. The light come on but it doesn't flash. The hazard lights work just fine along with the left turn signal. Ideas ?

Flowmaster 50 Series w/ 4" Tips
DDM Tuning 55w 5000k HID's
15" Custom Audioque HDC3, 35hz
2x Audiopipe 1800d's
Kenwood KDC-X996
Big 3 Upgrade
5901 Viper Alarm w/ Remote Start
1995 Chevy Caprice 4.3L L99
Nashville
Coolwazabi is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 03-24-2012, 09:59 PM
Senior Member
 
The Fooser Guy's Avatar
 
Join Date: Oct 2003
Location: STL-ish
Posts: 2,058
 
On the interior side of the firewall (inside the car), about where your left foot sits (but up a little higher) are two, round, silver relays (about the diameter of a half-dollar). Pull them out and push them back in.

Try the turn signals.

If that does not work, swap the relays and see if the problem goe to the left turn signal.

If it does, replace the defective relay (car parts store).

HTH

.

The Fooser Guy
"Diagonally parked in a parallel universe."

Quote:
Originally Posted by thebigbadWOLF View Post
Tested a coil by listening to MR.WOODS... ****ing coil WORKS just fine.... ass hole
'96 SOB Imp, 'Built' 355 LT-1, 3200 Street Edge, stage-3 4L60E, Unlimited drive shaft, 'bulletproof' 3.90's, Hydra intake, CIA headers, CIA 570 CFM cats, Pypes X-pipe, Dynomax VT's, dumped, Nitto 555's (255/70/15 ), Bilsteins, brake bolt mods, externally stock appearance.
The Fooser Guy is offline  
post #3 of 13 (permalink) Old 03-25-2012, 01:15 PM
Senior Member
 
AZ Roadmaster's Avatar
 
Join Date: Apr 2011
Location: Chandler, Az
Posts: 237
 
Garage
Take the hocky puck out, turn it 1/4 turn and re-install it, this should fix it!

[/SIGPIC]92 RMS, daily driver, project car, Eibach springs, Bilstein shocks, BMR rear upper and lower control arms, BMR front and rear sway bars, Dick Miller braces, Spohn spherical ft end links, fabricated ft sway frame support, ROH wheels with Nitto tires, replaced upper and lower control arms and all steering linkages and reman box. reprogramed ecu, tb spacer, adj. fp reg, cold air intake, electric fans, pully kit, SS rear with posi 3:73's Next big brake kit!
AZ Roadmaster is offline  
post #4 of 13 (permalink) Old 03-25-2012, 02:11 PM Thread Starter
Senior Member
 
Coolwazabi's Avatar
 
Join Date: Mar 2011
Location: Nashville
Posts: 158
 
Pulled both 1 out then both worked. Switched them and then none worked. There both different. Any idea what the model is suppose to be?

Flowmaster 50 Series w/ 4" Tips
DDM Tuning 55w 5000k HID's
15" Custom Audioque HDC3, 35hz
2x Audiopipe 1800d's
Kenwood KDC-X996
Big 3 Upgrade
5901 Viper Alarm w/ Remote Start
1995 Chevy Caprice 4.3L L99
Nashville
Coolwazabi is offline  
post #5 of 13 (permalink) Old 03-30-2012, 01:11 AM
Senior Member
 
shudahadaV8's Avatar
 
Join Date: Jan 2012
Location: Jersey Shore, NJ
Posts: 257
 
I think that one is for the turn signals and the other is for the emergency hazards and I don't remember which is for which, but if you pull one then the other you can quickly tell. I have a 95 "B" and always thought that both left and right turn signals share a single flasher (can't turn both ways at once). So if the one side flashes and the other doesn't ... well, that's odd. Turn signal switch ??
shudahadaV8 is offline  
post #6 of 13 (permalink) Old 04-28-2012, 09:06 PM
Junior Member
 
cavav8r's Avatar
 
Join Date: Jul 2010
Location: Lower Alabama
Posts: 13
 
Quote:
Originally Posted by The Fooser Guy View Post
On the interior side of the firewall (inside the car), about where your left foot sits (but up a little higher) are two, round, silver relays (about the diameter of a half-dollar). Pull them out and push them back in.

Try the turn signals.

If that does not work, swap the relays and see if the problem goe to the left turn signal.

If it does, replace the defective relay (car parts store).

HTH

.
nice!!! had the exact same problem (no hockey puck mod though) right turn signal sticks. swaped the relays and they both worked fine. here's the interesting part though. after swapping the hazards still work, but flash fast now. doesn't matter though, just glad it did the job! thanks guys!!!

'96 SS
250,000 Miles
Engine/Tranny replaced at 200,000
DO NOT BUY A JASPER MOTOR!!!!
Interior replaced at 180,000
cavav8r is offline  
post #7 of 13 (permalink) Old 04-28-2012, 10:08 PM
Senior Member
 
SimplyTheBeSS's Avatar
 
Join Date: Aug 2010
Location: St. Louis, MO
Posts: 2,418
 
Garage
Fooser is the smartest Guy I know!


1994 SS
- GRAIL Webmaster, St. Louis, MO
View our Tech/Guide page for everything from your basic oil change to Manual transmission swaps!

SimplyTheBeSS is offline  
post #8 of 13 (permalink) Old 04-29-2012, 01:12 AM
Senior Member
 
4x4high's Avatar
 
Join Date: Jan 2012
Location: Pleasanton, Ca.
Posts: 1,162
 
Garage
Send a message via Yahoo to 4x4high
Quote:
Originally Posted by cavav8r View Post
nice!!! had the exact same problem (no hockey puck mod though) right turn signal sticks. swaped the relays and they both worked fine. here's the interesting part though. after swapping the hazards still work, but flash fast now. doesn't matter though, just glad it did the job! thanks guys!!!
When a flasher goes bad the lights will either not blink at all or they blink super fast and i've seen the same thing when a bulb is bad (although if you checked the bulbs with either the turn signal or e-flasher and they worked it's not a bulb).
4x4high is offline  
post #9 of 13 (permalink) Old 10-18-2013, 04:43 PM
Senior Member
 
Biglou's Avatar
 
Join Date: Mar 2012
Location: HOUSTON,TEXAS
Posts: 371
 
I did all this already now the problem is the green arrow turns on with headlights only the drivers side and still doesn't blink

Biglou is offline  
post #10 of 13 (permalink) Old 10-18-2013, 05:03 PM
Senior Member
 
coltonx3's Avatar
 
Join Date: Feb 2011
Location: Colton CA
Posts: 933
 
i use the same flasher for the hazard for my turns it makes them blink faster i like it

95 9c1 dggm
straight black pvc kn filter
spintech pro street mufflers
most of trim and grill painted black
150k running strong and going

coltonx3 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome