Interior Lights - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 11-28-2012, 06:15 PM Thread Starter
Senior Member
 
Join Date: Sep 2007
Posts: 955
 
Interior Lights

Hi all!

My interior lights are not working properly. When I open the doors only the light under the dash and the lights on the door come on. The dome light, the two lights in the rear view mirror and the two rear lights on the coat hooks do not come on. But when I close the door, and the lights that ARE on, shut off then I can manually put the lights on on the rear view and the coat hooks. Can anyone help me in solving this problem? I checked for grounds, they look good. Car is a 94 B4U Caprice. Any help would be much appreciated.
fat boys ss is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-28-2012, 06:27 PM
Senior Member
 
4DoorSS's Avatar
 
Join Date: Nov 2008
Location: Beautiful Chester County, PA
Posts: 6,302
 
Did you check your fuses?

Is your vanity mirror out too? If so,there is a harness that supplies power to items you mentioned. Iirc this harness, runs up the driver side B Pillar. Pull the 2 pillar covers off and check for voltage there, damage to the harness, etc.

================================================== =============


'95 Caprice SS conversion - Bonny Buckets - 96 Column, Shifter and Console - 3.73 Gear and Herter tune - Z/28 Cluster - Blazer OH Console - Green/Pink bushings - Chromed Impala Wheels - Eibach Springs and Bilstein Shocks - Corvette Engine Dress - the list goes on and still more to do...it never ends.
4DoorSS is online now  
post #3 of 8 (permalink) Old 11-28-2012, 07:56 PM
Member
 
Join Date: Mar 2003
Location: Queens , N .Y.
Posts: 94
 
I have the same exact problem and can not find the cause. when I shift the car in when I shift the car in reverse the lights go ou pleasplease help

JOE
1996 BBB-:-(
SSTUNNER96 is offline  
post #4 of 8 (permalink) Old 11-28-2012, 08:24 PM Thread Starter
Senior Member
 
Join Date: Sep 2007
Posts: 955
 
Quote:
Originally Posted by 4DoorSS View Post
Did you check your fuses?

Is your vanity mirror out too? If so,there is a harness that supplies power to items you mentioned. Iirc this harness, runs up the driver side B Pillar. Pull the 2 pillar covers off and check for voltage there, damage to the harness, etc.

thanks a lot will look at the fuses
fat boys ss is offline  
post #5 of 8 (permalink) Old 11-28-2012, 11:15 PM
Member
 
Join Date: Mar 2003
Location: Queens , N .Y.
Posts: 94
 
I've been researching some old posts and I will be checking the green box(chimes) and interior relay under the drivers side dashboard just above the brake pedal.

JOE
1996 BBB-:-(
SSTUNNER96 is offline  
post #6 of 8 (permalink) Old 11-29-2012, 09:42 AM
Senior Member
 
Join Date: Feb 2001
Location: MI
Posts: 541
 
Quote:
Originally Posted by fat boys ss View Post
Hi all!

My interior lights are not working properly. When I open the doors only the light under the dash and the lights on the door come on. The dome light, the two lights in the rear view mirror and the two rear lights on the coat hooks do not come on. But when I close the door, and the lights that ARE on, shut off then I can manually put the lights on on the rear view and the coat hooks. Can anyone help me in solving this problem? I checked for grounds, they look good. Car is a 94 B4U Caprice. Any help would be much appreciated.
Since your door and dash lights work the interior lamp relay is OK.
Since you can manually turn on the mirror and rear lights they have power and the fuses are OK.

Some place from the lights not working and the interior lamp relay there is a break/bad connection in the dark blue/white wire. Since all the lights you mentioned are not working the break/bad connection must be after they splice into one wire. I would check starting where that wire goes down the B pillar to the relay.

96 DCM 1st Mod. 12way Bonneville seats!
Zebrafive is offline  
post #7 of 8 (permalink) Old 11-29-2012, 11:15 PM
Member
 
Join Date: Mar 2003
Location: Queens , N .Y.
Posts: 94
 
I found the problem on my 96 impala, I had a bad harness on the right side rear under the carpet inside the stock black wire loom that runs along the floor. I rewired and walah! everything works correctly now and i believe it was the blue/white wire that had a bad connection.

JOE
1996 BBB-:-(
SSTUNNER96 is offline  
post #8 of 8 (permalink) Old 12-01-2012, 07:41 PM Thread Starter
Senior Member
 
Join Date: Sep 2007
Posts: 955
 
Quote:
Originally Posted by Zebrafive View Post
Since your door and dash lights work the interior lamp relay is OK.
Since you can manually turn on the mirror and rear lights they have power and the fuses are OK.

Some place from the lights not working and the interior lamp relay there is a break/bad connection in the dark blue/white wire. Since all the lights you mentioned are not working the break/bad connection must be after they splice into one wire. I would check starting where that wire goes down the B pillar to the relay.
Got it it was the blue/white wire the had the break in it by the connecto right at the the bottom of the B pillar .the connecto was all f**ked up so i cut it out and soldered the wires together and it worked lol

thank you all for the help happy holidays
fat boys ss is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome