Fuel pump issues while ditching my CNG - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-29-2012, 04:18 PM Thread Starter
Junior Member
 
Join Date: Mar 2008
Location: Warrenville, Il
Posts: 12
 
Fuel pump issues while ditching my CNG

I'm having trouble with my 94 9c1. It used to have a CNG alternate fuel system that I got tired of hauling around and disassembled. Lately the car started stalling out suddenly while driving and in the process of trouble shooting it, I decided the octopus of a wiring harness had to go as well as all the left over CNG components as they only gave me extra variables to work with. Now that it is all gone, my fuel pump doesn't work. It doesn't prime and the car won't start. My service manual mentions a fuel pump test circuit but I'm not certain how to use it other than maybe shorting it with 12 volts, but I'm concerned that I might toast the circuit and compound my problems. Can anybody help me?
Slaticus is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-29-2012, 04:34 PM
Moderator
 
Goldmaster's Avatar
 
Join Date: Nov 2006
Location: Warren, MI
Posts: 9,682
 
The fuel pump test circuit is the lone red wire up by the underhood fuse/relay box. You just jump it to 12V (at the aux battery post). You could splice a 10-15Amp fuse into your test wire if you're concerned about shorting something out. I would try that and see what you're getting at the rear harness plug near the tank. The gray wire is the main power wire for the pump. If you jump out the test lead, you should have constant 12V at the gray wire in the back. If that's good and the pump is still not running with direct voltage applied, then likely the problem is in the tank with the pump and/or wiring harness. Just went through this with my 96 RMS on Friday. Found a bad in-tank wiring harness (burnt connection). Replaced pump and wiring and car is good to go now. Check the FP ground in the trunk as well (on the driver side trunk hinge support).
Goldmaster is offline  
post #3 of 8 (permalink) Old 01-30-2012, 09:35 PM Thread Starter
Junior Member
 
Join Date: Mar 2008
Location: Warrenville, Il
Posts: 12
 
Thanks for the input. I'll give it a shot and see what happens. I like the idea of splicing the fuse into it. I think I'll do that. If nobody hears from me for awhile, assume I figured it out or blew myself up trying. Thanks again.
Slaticus is offline  
post #4 of 8 (permalink) Old 01-31-2012, 12:11 PM Thread Starter
Junior Member
 
Join Date: Mar 2008
Location: Warrenville, Il
Posts: 12
 
New update: Fuel pump is unresponsive when using the test circuit. I hooked up a volt meter to the gray wire in the back and it was only reading 4 volts. I assumed that was likely due to the half-assed rigging with a series of vice grips to hold the jump in place while I went around to the back to test it and decided to skip the process altogher and just pulled my truck up the back and applied 12v directly from its battery to the fuel pump (yes I had the truck and car grounded together to complete the circuit). Still the fuel pump didn't do anything. It is a fairly new pump as it was replaced about 6 months ago. I recall that after I replaced it, I tested the fuel pressure and found it to be just a touch low. I assumed it was because the CNG system may have been robbing some voltage and decided it was good enough since I needed the car up and running and it was only slightly low. Perhaps that was a foolish assumption in retrospect. I was hoping not to have to drop the tank again. Before I tackle it (probably on my next day off) anybody care to interject?
Slaticus is offline  
post #5 of 8 (permalink) Old 01-31-2012, 02:55 PM
Senior Member
 
Mr pogo's Avatar
 
Join Date: Oct 2003
Location: SoCal
Posts: 6,358
 
in the stickies there is a fuel sender refurbishing link I suggest perusing.
your internal harness may be marginal, low voltage will kill a pump.

evil T-47 seatbelt bolts and cutdown ZQ8 bumpstops, Kore3 front brakes, TB bypass, Dynotech DS, F-body EGR, Meziere WP, Comp Cams 1.6RR/CM springs, trans by Moi Industries, Yank 3600, Earls trans cooler/rad cooler delete/Derale t-stat, RAISS, SLP headers, SLP injectors, pypes X-pipe/magnaflows, Borgeson shaft, Hotchkis springs, PPM front stuff, Metco rear arms, Clear Image DS loop/trans crossmember, 3.73s, eaton posi, Hypertech for smog \"[<img BH tuned PCM
Mr pogo is offline  
post #6 of 8 (permalink) Old 02-03-2012, 02:53 PM
Moderator
 
Goldmaster's Avatar
 
Join Date: Nov 2006
Location: Warren, MI
Posts: 9,682
 
Also, just curious with what you did with the CNG stuff. Did you sell it? Got any pics of it installed on the car?
Goldmaster is offline  
post #7 of 8 (permalink) Old 02-07-2012, 02:10 PM Thread Starter
Junior Member
 
Join Date: Mar 2008
Location: Warrenville, Il
Posts: 12
 
I don't have any pics of the CNG system on the car. I still have it all though. Was considering selling it. I'm not really sure what to do with it. As far as I know it is a complete system but it hasnt' been used in years.
Slaticus is offline  
post #8 of 8 (permalink) Old 02-19-2012, 08:53 PM Thread Starter
Junior Member
 
Join Date: Mar 2008
Location: Warrenville, Il
Posts: 12
 
Ok everyone... finally back on the road! It turned out to be a wiring harness issue after all. Inside the trunk on the drivers side there is a connection mounted on the inside of the rear quarter that shorted out somehow and melted into a charred ball of plastic and oxidized wires. Chopped that out and put in a new connector and she's running fine. Finally! I just wish I had more time to put into it so I could have figured it out sooner. Thanks for all your input guys.
Slaticus is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome