Transmission shudder - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-05-2009, 09:37 PM Thread Starter
Junior Member
 
Join Date: Dec 2007
Posts: 22
 
Transmission shudder

Labor day weekend the 2-4 servo snap ring popped out. I replaced the snap ring and the shifts great but it shudders sometimes under 10mph. What could cause this? The transmission is full and the fluid is nice and red. Other than the it shifts fine. Thanks
fastchevrolet350 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-17-2009, 04:32 PM
Senior Member
 
TripKidd's Avatar
 
Join Date: Jul 2004
Location: Moline, Il
Posts: 106
 
I'm experiencing the same symptoms with a repaired trans I got back in yesterday...

anyone have any ideas?

1994 Caprice, extra speed holes.

14.2 @ 96MPH
TripKidd is offline  
post #3 of 3 (permalink) Old 11-17-2009, 09:52 PM
Sophomore Member
 
Join Date: May 2003
Location: Huntsville, AL
Posts: 8,089
 
Send a message via AIM to sherlock9c1
shuddering under 10mph? Is it trying to shift?

"The unexamined life is not worth living." - Socrates
sherlock9c1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome