A/C System - Chevy Impala SS Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 07-18-2016, 08:21 AM Thread Starter
Senior Member
 
6 speed V's Avatar
 
Join Date: Feb 2010
Location: Dover, De
Posts: 270
 
A/C System

I have a leak in my A/C system, not sure if it is the compressor or bad line, I am thinking bad line (they were persuaded for header install, bet I cracked one). I added a can and it pretty much leaked out all over the floor overnight, and the compressor does not come on.


Anyway, thinking of replacing the lines, compressor, and dryer, pretty sure they are all factory age, or never replaced.


Where is a good source to get parts, esp. the lines?


Thanks
6 speed V is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 07-18-2016, 10:16 AM
Senior Member
 
babywag's Avatar
 
Join Date: Mar 2016
Location: California
Posts: 349
 
I bought all new stuff from rockauto and ebay.
Some of the acdelco stuff was poor quality and returned.

Wound up using UAC lines and condenser, not 100%, but worked fine.
Lines fit fine, added some foil heat tape like OE, and had to bend condenser lines a 'bit to fit properly.
The ACDelco equivalents were crap and got returned. Sad but not even close to worth extra $ vs. UAC parts.

YMMV
babywag is offline  
post #3 of 12 (permalink) Old 07-18-2016, 11:41 AM Thread Starter
Senior Member
 
6 speed V's Avatar
 
Join Date: Feb 2010
Location: Dover, De
Posts: 270
 
Quote:
Originally Posted by babywag View Post
I bought all new stuff from rockauto and ebay.
Some of the acdelco stuff was poor quality and returned.

Wound up using UAC lines and condenser, not 100%, but worked fine.
Lines fit fine, added some foil heat tape like OE, and had to bend condenser lines a 'bit to fit properly.
The ACDelco equivalents were crap and got returned. Sad but not even close to worth extra $ vs. UAC parts.

YMMV



Thanks for the info, I'll take a look.


Mike
6 speed V is offline  
 
post #4 of 12 (permalink) Old 07-18-2016, 12:02 PM
Senior Member
 
babywag's Avatar
 
Join Date: Mar 2016
Location: California
Posts: 349
 
Other option if you have a local outfit that does hoses for a reasonable price is to just get yours redone?

Around here it's ~$50-$70 per hose, so it was lots cheaper to just replace the hose assembly, but probably should have just ponied up the extra $ to redo them.
babywag is offline  
post #5 of 12 (permalink) Old 07-18-2016, 12:29 PM
Senior Member
 
Join Date: Oct 2011
Location: Atlanta
Posts: 481
 
Agree with getting your hoses re-done locally. Also, do NOT get the AC-Declo condenser. Its garbage


1995 Caprice ERE 383, CIA long tubes, Dynomax VT's, RAISS, Kore3/Z06 brakes, 3.42 posi, Boss 338 20's, 12 way seats, Impala SS console, etc etc etc
atlantadan is online now  
post #7 of 12 (permalink) Old 07-23-2016, 01:31 AM
Senior Member
 
4x4high's Avatar
 
Join Date: Jan 2012
Location: Pleasanton, Ca.
Posts: 1,252
 
Garage
Send a message via Yahoo to 4x4high
Just yesterday I had a NEW Delphi compressor and accumulator installed. The shop charged me $255 for the compressor and $25 for the accumulator. My compressor is what leaked and it was the original 20 year old part.

1996 DGGM Impala SS
4x4high is online now  
post #8 of 12 (permalink) Old 07-23-2016, 10:10 PM
Senior Member
 
babywag's Avatar
 
Join Date: Mar 2016
Location: California
Posts: 349
 
Quote:
Originally Posted by 4x4high View Post
Just yesterday I had a NEW Delphi compressor and accumulator installed. The shop charged me $255 for the compressor and $25 for the accumulator. My compressor is what leaked and it was the original 20 year old part.
Hope it works out for you. The brand new Delphi I bought from jegs.com was bad right out of box. Clutch was defective and didn't show until it was installed. Had to remove it and send it back.
Cost me $32 in refrigerant, and had to pay return shipping.
Real disappointment but seems par for course with made in China crap these days.
babywag is offline  
post #9 of 12 (permalink) Old 07-23-2016, 10:35 PM
Senior Member
 
4x4high's Avatar
 
Join Date: Jan 2012
Location: Pleasanton, Ca.
Posts: 1,252
 
Garage
Send a message via Yahoo to 4x4high
Quote:
Originally Posted by babywag View Post
Hope it works out for you. The brand new Delphi I bought from jegs.com was bad right out of box. Clutch was defective and didn't show until it was installed. Had to remove it and send it back.
Cost me $32 in refrigerant, and had to pay return shipping.
Real disappointment but seems par for course with made in China crap these days.
That's the beauty of paying a shop to do the work, IF the part fails I just drop the car off and let them deal with it.

1996 DGGM Impala SS
4x4high is online now  
post #10 of 12 (permalink) Old 07-24-2016, 12:01 AM
Senior Member
 
babywag's Avatar
 
Join Date: Mar 2016
Location: California
Posts: 349
 
Quote:
Originally Posted by 4x4high View Post
That's the beauty of paying a shop to do the work, IF the part fails I just drop the car off and let them deal with it.
True, but jegs.com Delphi $169 I bought only had 1yr warranty, @ least it crapped out immediately.
Replacement I bought this round was $226 and is lifetime warranty.
So next time it fails it'll be cheaper lol.

~$350 in parts only original part is evaporator now.
Hopefully won't have to touch it for while.
babywag is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome