did a new water pump install,forgot o rings... - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-13-2012, 10:44 AM Thread Starter
Member
 
superboosted's Avatar
 
Join Date: Dec 2011
Location: Northeast,PA
Posts: 68
 
did a new water pump install,forgot o rings...

Do I need to pull the pump back off? Is this the end? On the pump drive BTW please say its ok,I don't want to pull it apart again.

1996 Caprice Classic B4U

SS wheels,resonators removed,side trim removed,ecu tune,hawk pads,Goodyear hoses,A.I.R. removed...for starters.
superboosted is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-13-2012, 12:55 PM
Senior Member
 
Join Date: Mar 2004
Location: Sactown,Kalifornia..916
Posts: 834
 
pull it off and install the o-rings. It can be a pain but Id do it if I were you.

95 DCM Imp SS....Daily Driver 98k and counting
72 Cutty............Weekend cruiser.
Nor-CalSS is offline  
post #3 of 6 (permalink) Old 02-13-2012, 02:42 PM
Senior Member
 
Join Date: Oct 2010
Posts: 100
 
Quote:
Originally Posted by superboosted View Post
Do I need to pull the pump back off? Is this the end? On the pump drive BTW please say its ok,I don't want to pull it apart again.
I just did a water pump replacement and it seems those o rings are very durable. whats year is your impala? I wouldnt sweat it.
561 B-Body Boy is offline  
post #4 of 6 (permalink) Old 02-13-2012, 02:46 PM Thread Starter
Member
 
superboosted's Avatar
 
Join Date: Dec 2011
Location: Northeast,PA
Posts: 68
 
Well,I think I am going to wait a.week or two as I have to tear it down again to convert to electric fans and change opti/wires,looks like all it does is keep out dirt?
Also need to decide if I want to keep the ac pump as that is squeaking now of course.

1996 Caprice Classic B4U

SS wheels,resonators removed,side trim removed,ecu tune,hawk pads,Goodyear hoses,A.I.R. removed...for starters.
superboosted is offline  
post #5 of 6 (permalink) Old 02-13-2012, 02:58 PM
Senior Member
 
Mr pogo's Avatar
 
Join Date: Oct 2003
Location: SoCal
Posts: 6,358
 
youre supposed to grease the coupler splines on reassembly and the o-rings keep the grease in and moisture out.
without the grease or in high moisture areas the coupler rusts to the splines.

evil T-47 seatbelt bolts and cutdown ZQ8 bumpstops, Kore3 front brakes, TB bypass, Dynotech DS, F-body EGR, Meziere WP, Comp Cams 1.6RR/CM springs, trans by Moi Industries, Yank 3600, Earls trans cooler/rad cooler delete/Derale t-stat, RAISS, SLP headers, SLP injectors, pypes X-pipe/magnaflows, Borgeson shaft, Hotchkis springs, PPM front stuff, Metco rear arms, Clear Image DS loop/trans crossmember, 3.73s, eaton posi, Hypertech for smog \"[<img BH tuned PCM
Mr pogo is offline  
post #6 of 6 (permalink) Old 02-13-2012, 03:03 PM
Senior Member
 
Join Date: Jul 2005
Location: Los Angeles
Posts: 3,392
 
You do need to replace the o-rings and you should pack the shaft connector with wheel bearing grease.

Jim B.

'95 9c1, pcmperformance.com 93 tune, Dynomax Ultraflo catback, K & N box filter, LT4 KM, 160 stat, 3.08 Posi.
fbi9c1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome