Awww Hell, I have a leak.... - Chevy Impala SS Forum
Impala SS Forum
Go Back   Chevy Impala SS Forum > 91-96 Impala/B-body > Engine Problems/Maintenance
New User? Register - Forgot Password

Reply
 
Thread Tools Display Modes
  #1  
Old 10-19-2011, 09:23 AM
Cracka Ass Crackuh's Avatar
Cracka Ass Crackuh Cracka Ass Crackuh is offline
Signature Section Moderator & CrossFire Club Ambassador of Kwan
 
Join Date: Oct 2004
Location: MISK Section
Posts: 15,703
Cracka Ass Crackuh is an unknown quantity at this point
Default Awww Hell, I have a leak....

And yes, it's on the car....


Looks like I'm leaving small puddles of oil which appears to be coming from behind the crank pulley....


Please tell me this isn't going to be THAT expensive to fix
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-19-2011, 09:25 AM
thebigbadWOLF's Avatar
thebigbadWOLF thebigbadWOLF is offline
Senior Member
 
Join Date: Feb 2007
Location: La Puente
Posts: 9,168
thebigbadWOLF is an unknown quantity at this point
Default

Quote:
Originally Posted by Cracka Ass Crackuh View Post
And yes, it's on the car....


Looks like I'm leaving small puddles of oil which appears to be coming from behind the crank pulley....


Please tell me this isn't going to be THAT expensive to fix
how about some helpfull information like
year
motor
type
asl
do you like long walks on the beach...?
__________________
Cali-SS


Quote:
Originally Posted by Rocko350 View Post
Go fix your fleet of 91's. I wipes my tushy with TBI.......
Quote:
Originally Posted by Needles.Kain View Post
Much like date night with BK, this isn't about what you prefer.
Reply With Quote Quick reply to this message
  #3  
Old 10-19-2011, 09:40 AM
juniorwatson's Avatar
juniorwatson juniorwatson is offline
Senior Member
 
Join Date: Aug 2007
Location: State College, PA
Posts: 1,490
juniorwatson is on a distinguished road
Send a message via ICQ to juniorwatson
Default

Is it dripping down the front of the timing chain cover?

Is it as simple as the hub seal?
__________________
'96 - W/'96 9C1 Rear. Blah, Blah, Blah....

Reply With Quote Quick reply to this message
  #4  
Old 10-19-2011, 09:47 AM
TheImpalaMan's Avatar
TheImpalaMan TheImpalaMan is offline
Member
 
Join Date: Mar 2004
Location: Houston
Posts: 62
TheImpalaMan is an unknown quantity at this point
Send a message via ICQ to TheImpalaMan
Default

Again, what year is your car?

If it's got the optispark, it could be one of 3 seals on the timing chain cover.

Water Pump drive seal
OptiSpark seal
Harmonic Balance Hub seal

Hopefully it is either the water pump drive or the optispark seal. They are the easiest to change of the 3.

-TheImpalaMan
__________________
Black 1996 Impala SS Modified. 205k Miles & Still Rockin Hard!

Reply With Quote Quick reply to this message
  #5  
Old 10-19-2011, 09:51 AM
Cracka Ass Crackuh's Avatar
Cracka Ass Crackuh Cracka Ass Crackuh is offline
Signature Section Moderator & CrossFire Club Ambassador of Kwan
 
Join Date: Oct 2004
Location: MISK Section
Posts: 15,703
Cracka Ass Crackuh is an unknown quantity at this point
Default

D'oh! Such a n00wb mistake....


95 Caprice Wagon
Marblehead silver
LT1
162,000 miles

Just had the opti done 6 months ago, had the water pump done last week....

29/m/Tx

No, not a big fan of long walks on the beach.... mostly because I'm walking to the next gas station....
Reply With Quote Quick reply to this message
  #6  
Old 10-19-2011, 09:56 AM
Synaptic's Avatar
Synaptic Synaptic is offline
Super Moderator
 
Join Date: Oct 2000
Location: North Carolina
Posts: 7,839
Synaptic has a little shameless behaviour in the past
Default

Dont you do anything yourself crackah?
Reply With Quote Quick reply to this message
  #7  
Old 10-19-2011, 10:02 AM
Moby Dick's Avatar
Moby Dick Moby Dick is offline
Senior Member
 
Join Date: Dec 2002
Location: Raleigh, NC
Posts: 3,317
Moby Dick has a little shameless behaviour in the past
Send a message via AIM to Moby Dick Send a message via Yahoo to Moby Dick
Default

Quote:
Originally Posted by Cracka Ass Crackuh View Post
D'oh! Such a n00wb mistake....


95 Caprice Wagon
Marblehead silver
LT1
162,000 miles

Just had the opti done 6 months ago, had the water pump done last week....

29/m/Tx

No, not a big fan of long walks on the beach.... mostly because I'm walking to the next gas station....
Probably the seal for the WP drive since you just replaced the WP recently. Easy enough to pinch.
__________________
Eric Seaman

1994 Caprice Wagon "Moby Dick"
1996 Impala SS 383 11.604@117 CC503 with 3.73's.
"Fastest NA 383 3.73 equipped car on the board"
ISSCA Member #2517
Reply With Quote Quick reply to this message
  #8  
Old 10-19-2011, 10:07 AM
thebigbadWOLF's Avatar
thebigbadWOLF thebigbadWOLF is offline
Senior Member
 
Join Date: Feb 2007
Location: La Puente
Posts: 9,168
thebigbadWOLF is an unknown quantity at this point
Default

+1 @ wp
__________________
Cali-SS


Quote:
Originally Posted by Rocko350 View Post
Go fix your fleet of 91's. I wipes my tushy with TBI.......
Quote:
Originally Posted by Needles.Kain View Post
Much like date night with BK, this isn't about what you prefer.
Reply With Quote Quick reply to this message
  #9  
Old 10-19-2011, 10:08 AM
LT Scholz LT Scholz is offline
Banned
 
Join Date: Feb 2011
Location: Insane Asylum of Doom
Posts: 1,248
LT Scholz is on a distinguished road
Default

I thought you did your own auto work or at least had someone help you.

I'm certain that your opti seal is shot, if not also the water pump seal. Not just because it is easily apparent but because my original opti died from similar causes. If memory serves me right your seal is going to eventually explode shorting out your optical disks. This will sound like a big thud, the car will die, and you will be stranded.
Reply With Quote Quick reply to this message
  #10  
Old 10-19-2011, 10:09 AM
juniorwatson's Avatar
juniorwatson juniorwatson is offline
Senior Member
 
Join Date: Aug 2007
Location: State College, PA
Posts: 1,490
juniorwatson is on a distinguished road
Send a message via ICQ to juniorwatson
Default

Don't forget to do the 2 O-rings on the WP drive shaft coupler as well if/when you do the shaft seal.
__________________
'96 - W/'96 9C1 Rear. Blah, Blah, Blah....

Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:47 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
(c) 2007-2014 Impala SS Forum