Interior Lights - Chevy Impala SS Forum
Impala SS Forum
Go Back   Chevy Impala SS Forum > 91-96 Impala/B-body > Electrical
New User? Register - Forgot Password

Reply
 
Thread Tools Display Modes
  #1  
Old 11-28-2012, 06:15 PM
fat boys ss fat boys ss is offline
Senior Member
 
Join Date: Sep 2007
Posts: 719
fat boys ss is on a distinguished road
Default Interior Lights

Hi all!

My interior lights are not working properly. When I open the doors only the light under the dash and the lights on the door come on. The dome light, the two lights in the rear view mirror and the two rear lights on the coat hooks do not come on. But when I close the door, and the lights that ARE on, shut off then I can manually put the lights on on the rear view and the coat hooks. Can anyone help me in solving this problem? I checked for grounds, they look good. Car is a 94 B4U Caprice. Any help would be much appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-28-2012, 06:27 PM
4DoorSS's Avatar
4DoorSS 4DoorSS is offline
Senior Member
 
Join Date: Nov 2008
Location: Beautiful Chester County, PA
Posts: 4,402
4DoorSS is an unknown quantity at this point
Default

Did you check your fuses?

Is your vanity mirror out too? If so,there is a harness that supplies power to items you mentioned. Iirc this harness, runs up the driver side B Pillar. Pull the 2 pillar covers off and check for voltage there, damage to the harness, etc.
__________________
================================================== =============


'95 Caprice SS conversion - Bonny Buckets - 96 Column, Shifter and Console - 3.73 Gear and Herter tune - Z/28 Cluster - Blazer OH Console - Green/Pink bushings - Chromed Impala Wheels - Eibach Springs and Bilstein Shocks - Corvette Engine Dress - the list goes on and still more to do...it never ends.
Reply With Quote Quick reply to this message
  #3  
Old 11-28-2012, 07:56 PM
SSTUNNER96 SSTUNNER96 is offline
Member
 
Join Date: Mar 2003
Location: Queens , N .Y.
Posts: 87
SSTUNNER96
Default

I have the same exact problem and can not find the cause. when I shift the car in when I shift the car in reverse the lights go ou pleasplease help
__________________
JOE
1996 BBB-:-(
Reply With Quote Quick reply to this message
  #4  
Old 11-28-2012, 08:24 PM
fat boys ss fat boys ss is offline
Senior Member
 
Join Date: Sep 2007
Posts: 719
fat boys ss is on a distinguished road
Default

Quote:
Originally Posted by 4DoorSS View Post
Did you check your fuses?

Is your vanity mirror out too? If so,there is a harness that supplies power to items you mentioned. Iirc this harness, runs up the driver side B Pillar. Pull the 2 pillar covers off and check for voltage there, damage to the harness, etc.

thanks a lot will look at the fuses
Reply With Quote Quick reply to this message
  #5  
Old 11-28-2012, 11:15 PM
SSTUNNER96 SSTUNNER96 is offline
Member
 
Join Date: Mar 2003
Location: Queens , N .Y.
Posts: 87
SSTUNNER96
Default

I've been researching some old posts and I will be checking the green box(chimes) and interior relay under the drivers side dashboard just above the brake pedal.
__________________
JOE
1996 BBB-:-(
Reply With Quote Quick reply to this message
  #6  
Old 11-29-2012, 09:42 AM
Zebrafive Zebrafive is offline
Senior Member
 
Join Date: Feb 2001
Location: MI
Posts: 520
Zebrafive
Default

Quote:
Originally Posted by fat boys ss View Post
Hi all!

My interior lights are not working properly. When I open the doors only the light under the dash and the lights on the door come on. The dome light, the two lights in the rear view mirror and the two rear lights on the coat hooks do not come on. But when I close the door, and the lights that ARE on, shut off then I can manually put the lights on on the rear view and the coat hooks. Can anyone help me in solving this problem? I checked for grounds, they look good. Car is a 94 B4U Caprice. Any help would be much appreciated.
Since your door and dash lights work the interior lamp relay is OK.
Since you can manually turn on the mirror and rear lights they have power and the fuses are OK.

Some place from the lights not working and the interior lamp relay there is a break/bad connection in the dark blue/white wire. Since all the lights you mentioned are not working the break/bad connection must be after they splice into one wire. I would check starting where that wire goes down the B pillar to the relay.
__________________
96 DCM 1st Mod. 12way Bonneville seats, MOMO shift knob,Gentex Homelink comp/temp mirror,more to come!
Reply With Quote Quick reply to this message
  #7  
Old 11-29-2012, 11:15 PM
SSTUNNER96 SSTUNNER96 is offline
Member
 
Join Date: Mar 2003
Location: Queens , N .Y.
Posts: 87
SSTUNNER96
Default

I found the problem on my 96 impala, I had a bad harness on the right side rear under the carpet inside the stock black wire loom that runs along the floor. I rewired and walah! everything works correctly now and i believe it was the blue/white wire that had a bad connection.
__________________
JOE
1996 BBB-:-(
Reply With Quote Quick reply to this message
  #8  
Old 12-01-2012, 07:41 PM
fat boys ss fat boys ss is offline
Senior Member
 
Join Date: Sep 2007
Posts: 719
fat boys ss is on a distinguished road
Default

Quote:
Originally Posted by Zebrafive View Post
Since your door and dash lights work the interior lamp relay is OK.
Since you can manually turn on the mirror and rear lights they have power and the fuses are OK.

Some place from the lights not working and the interior lamp relay there is a break/bad connection in the dark blue/white wire. Since all the lights you mentioned are not working the break/bad connection must be after they splice into one wire. I would check starting where that wire goes down the B pillar to the relay.
Got it it was the blue/white wire the had the break in it by the connecto right at the the bottom of the B pillar .the connecto was all f**ked up so i cut it out and soldered the wires together and it worked lol

thank you all for the help happy holidays
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:05 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
(c) 2007-2014 Impala SS Forum