Fuel pump or tank not sealed properly????? - Chevy Impala SS Forum
Impala SS Forum
Go Back   Chevy Impala SS Forum > 91-96 Impala/B-body > Engine Problems/Maintenance
New User? Register - Forgot Password

Reply
 
Thread Tools Display Modes
  #1  
Old 12-03-2012, 02:56 AM
impalariviera's Avatar
impalariviera impalariviera is offline
Junior Member
 
Join Date: Mar 2009
Location: Hartford CT
Posts: 22
impalariviera is on a distinguished road
Default Fuel pump or tank not sealed properly?????

Under hard acceleration especially in corners my car feels as if its going to cut off it does this for a split second then it takes off like its supposed to... Another thing I've noticed since changing the fuel pump, is after sitting for a few minutes my car has trouble starting unless I cycle the ignition a few times to prime fuel pump , it's as if the tank is bleeding off the fuel pressure . I'm thinking its the gasket (rubber) that goes in to seal tank on top. And light shed on my issue would be appreciated.....
__________________
1996 BBB 22inch asanti af115s . #41700 of 41934 order #366RY8. 2nd new trans level 3 this time and 373s
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-03-2012, 10:41 PM
cletus284 cletus284 is offline
Senior Member
 
Join Date: Oct 2004
Location: STL, MO
Posts: 3,612
cletus284 is an unknown quantity at this point
Default

The tank seal has nothing to do with the fuel pressure supplied to the engine. Either a bad anti-drainback valve on the pump or a small leak between the pump and sending unit.
__________________
2005 Pontiac GTO
Reply With Quote Quick reply to this message
  #3  
Old 12-05-2012, 04:33 PM
impalariviera's Avatar
impalariviera impalariviera is offline
Junior Member
 
Join Date: Mar 2009
Location: Hartford CT
Posts: 22
impalariviera is on a distinguished road
Default

Thanks Cletus284 !! Ill definitely look into that as soon as I get my car back from the local speed shop they've taken almost a week and a half to do the 373s. I appreciate the reply....
__________________
1996 BBB 22inch asanti af115s . #41700 of 41934 order #366RY8. 2nd new trans level 3 this time and 373s
Reply With Quote Quick reply to this message
  #4  
Old 12-13-2012, 05:34 PM
impalariviera's Avatar
impalariviera impalariviera is offline
Junior Member
 
Join Date: Mar 2009
Location: Hartford CT
Posts: 22
impalariviera is on a distinguished road
Default

Well my fp went the other night and while dropping the tank I noticed that the quick connect hose in the middle came off by hand , so after putting it all together I made sure the hoses were all the way on and after installation it started right up .. Let it sit for about a half hour and voila it started right back up no more turning the ignition 3-4 times to prime pump!! Thanks for the pointers guys!!!
__________________
1996 BBB 22inch asanti af115s . #41700 of 41934 order #366RY8. 2nd new trans level 3 this time and 373s
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:33 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
(c) 2007-2014 Impala SS Forum