L05 blowing oil into air filter housing...fix? - Chevy Impala SS Forum
Impala SS Forum
Go Back   Chevy Impala SS Forum > 91 thru 96 B-body Model Specific > Wagons
New User? Register - Forgot Password

Reply
 
Thread Tools Display Modes
  #1  
Old 01-07-2013, 08:48 PM
CID Vicious's Avatar
CID Vicious CID Vicious is offline
Member
 
Join Date: Dec 2007
Posts: 54
CID Vicious is on a distinguished road
Default L05 blowing oil into air filter housing...fix?

Got a 92 L05 Caprice wagon, 220k, that's having some kind of positive crankcase pressure issue - I put a new PCV in and it's still pushing oil up into the air filter box near the injectors. The car had some really gunky oil in it that just got changed.

I'm looking at taking this car on a long trip in the next few weeks. I'd like to get the issue sorted out before I leave if I can.

It mostly runs fine. The 'low oil level' (LOL) light comes on pretty frequently even though I check the oil and it's never low.

???
__________________
94 RMS Limited, TB Bypass, 1st/Home delete, ported airbox, Spectre panel filter, Muffler/Overaxle delete, SS wheels with Contisport Contact2s in 245/45/17, wooden body mounts (stiffer than air!), G80, tow package, Gran Touring Suspension (now with Hotchkis springs), Grant 737 steering wheel

Poor Man's SS/Grandpa's Revenge Budget Build here: http://actuallysmartcarblog.blogspot.com/
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-07-2013, 10:47 PM
GoldSSWagon's Avatar
GoldSSWagon GoldSSWagon is offline
Senior Member
 
Join Date: Oct 2002
Location: Albuquerque
Posts: 1,913
GoldSSWagon is an unknown quantity at this point
Default

I'd do a wet/dry compression test first.
__________________
1995 Gold Caprice Wagon
1991 White Caprice Wagon
1991 Olds Custom Cruiser Wagon Sold
1995 RMW under construction
2004 Impala SS
2012 Chevy Terrain SL2
1974 BD-5T WIP
Reply With Quote Quick reply to this message
  #3  
Old 01-08-2013, 04:40 AM
wytltng's Avatar
wytltng wytltng is offline
Senior Member
 
Join Date: Nov 2009
Location: Southeast Mi
Posts: 4,654
wytltng is on a distinguished road
Default

Make sure you have suction on the pcv hose with engine running. If ok I would say you have bad rings.
Reply With Quote Quick reply to this message
  #4  
Old 01-08-2013, 12:57 PM
Fred Kiehl's Avatar
Fred Kiehl Fred Kiehl is online now
Senior Member
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 8,328
Fred Kiehl is on a distinguished road
Default

Quote:
Originally Posted by CID Vicious View Post
Got a 92 L05 Caprice wagon, 220k, that's having some kind of positive crankcase pressure issue - I put a new PCV in and it's still pushing oil up into the air filter box near the injectors. The car had some really gunky oil in it that just got changed.

I'm looking at taking this car on a long trip in the next few weeks. I'd like to get the issue sorted out before I leave if I can.

It mostly runs fine. The 'low oil level' (LOL) light comes on pretty frequently even though I check the oil and it's never low.

???
Putting a new pcv valve would probably make the situation worse. My first guess is the same as wytlting...bad or broken rings. Does it smoke?

My low oil light is on a lot, and it is probably a bad connection. You could also have a drainback issue on one side of the engine. If the oil level in the head is high, the oil could be sucked into the pcv system (BTW there are 2 pcv valves, one on each bank. If you have a drainback issue, it could also make your low oil light come on, because the oil is staying in the head, instead of the pan.
__________________
1991 OCC upgraded LO5, LT1 cam, 46mm TBI, bored intake manifold, wrapped headers, true duals w/Flowmasters, 3.23 posi, flash to pass, drop spindles & springs, custom fender skirts, stainless full moons, Recaros, Blazer console, Nardi/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, SS wheels. DEH P77DH
For a parts list, check Plenty of good parts
Reply With Quote Quick reply to this message
  #5  
Old 01-08-2013, 06:31 PM
CID Vicious's Avatar
CID Vicious CID Vicious is offline
Member
 
Join Date: Dec 2007
Posts: 54
CID Vicious is on a distinguished road
Default

Well there's just an elbow at the passenger side of the motor. I'm guessing it's supposed to be a PCV also, and I have the one I took off. I never tested it, just replaced it, so that's possibly it.

This thing has dumb 'repairs' all over it, missing sway bar bushings (?), so if someone 'replaced' a PCV with a plain old elbow I'd be less than surprised.

The car makes good power for what it is so I'd be surprised if I had rings going, and it doesn't smoke.

I'll throw the old PCV in the passenger side bank and put the new filter in, and see how dirty it gets.
__________________
94 RMS Limited, TB Bypass, 1st/Home delete, ported airbox, Spectre panel filter, Muffler/Overaxle delete, SS wheels with Contisport Contact2s in 245/45/17, wooden body mounts (stiffer than air!), G80, tow package, Gran Touring Suspension (now with Hotchkis springs), Grant 737 steering wheel

Poor Man's SS/Grandpa's Revenge Budget Build here: http://actuallysmartcarblog.blogspot.com/
Reply With Quote Quick reply to this message
  #6  
Old 01-08-2013, 06:53 PM
Fred Kiehl's Avatar
Fred Kiehl Fred Kiehl is online now
Senior Member
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 8,328
Fred Kiehl is on a distinguished road
Default

If it continues to suck oil, You should pull the valve cover, and check for oil drainage issues. The engine will suck a little oil through the passenger's side vent, into the intake plenum chamber. It is a strange setup.

My passenger's side valve cover looked like it had just an elbow, but when I pulled on it, it turned out to be a PCV valve.
__________________
1991 OCC upgraded LO5, LT1 cam, 46mm TBI, bored intake manifold, wrapped headers, true duals w/Flowmasters, 3.23 posi, flash to pass, drop spindles & springs, custom fender skirts, stainless full moons, Recaros, Blazer console, Nardi/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, SS wheels. DEH P77DH
For a parts list, check Plenty of good parts
Reply With Quote Quick reply to this message
  #7  
Old 01-08-2013, 07:12 PM
waynes91's Avatar
waynes91 waynes91 is offline
Senior Member
 
Join Date: Mar 2005
Location: groton ct
Posts: 1,644
waynes91
Default

had a problem with the tube on the tbi was plugged up,had to use a drill to clean it out (was able to turn drill by hand) been no problems after that
Reply With Quote Quick reply to this message
  #8  
Old 01-14-2013, 09:04 PM
sprocket's Avatar
sprocket sprocket is offline
Senior Member
 
Join Date: Jul 2007
Location: Delray Beach, FL
Posts: 3,618
sprocket is an unknown quantity at this point
Default

I had the same issue on my 1973 Poncho Gran Ville w/455.
My air filter would actually drip oil it got so wet. Pulled the valve covers and poked the return holes with a coat hanger. It helped some, but I sold the car two weeks later (needed tires, a new vert top, etc etc) so not really sure how well it worked. they were clogged pretty badly, engine was super dirty in there....
__________________
Reply With Quote Quick reply to this message
  #9  
Old 01-14-2013, 09:43 PM
convert2diesel convert2diesel is offline
Senior Member
 
Join Date: Apr 2004
Location: Ottawa, Canada
Posts: 443
convert2diesel
Default

Before ripping the engine apart, check three things.

1. The PCV port in the throttle body tends to carbon up in these engines. You still get some vacuum but not enough flow. You may have to remove the throttle body to get it really clean.

2. Pull the valve covers and check the oil return ports. Had 91 with same issue and found the return ports plugged solid with gunk. Cleaned out the ports and problem solved.

3. Replace PCV just on spec. Get one from the dealer. Their cheap and I have had a few bad ones right out of the box when buying aftermarket ones.

Only after checking these things would I start going deeper. For the price of a few gaskets its also good insurance. All of these things happen over time so its not a question of if, but rather a question of when.

Bill
__________________
91 Roadmaster Wagon, 6.2 diesel (gone but not forgotten)
91 Roadmaster Wagon, (gone to make toasters and refrigerators),
94 Fleetwood (thanks Fred) "Misty the tug boat" maybe the next diesel victim
05 Pontiac Grand Am...feeling less inadequate now
26 ft. Aerolite Cub Travel trailer
Reply With Quote Quick reply to this message
  #10  
Old 01-15-2013, 01:16 PM
Allan H. Allan H. is offline
Senior Member
 
Join Date: Jun 2009
Location: Northeast Ohio
Posts: 142
Allan H. is on a distinguished road
Default

The way the system is designed it supposed to pull any vapors the PCV system can't handle, like excessive blow-by from wear, back through the passenger's side vent tube and then into the air cleaner.
There can't be a PCV valve in the passenger side valve cover or the system wouldn't work right? That's the PCV air intake and it would build up vac inside the engine and start sucking oil and air from anywhere it could.
Blowing through A PCV valve outlet should close it up on a good valve and that is the flow direction needed for the air being pulled into the engine for the system.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:32 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
(c) 2007-2014 Impala SS Forum