Heater Core?? - Chevy Impala SS Forum
Impala SS Forum
Go Back   Chevy Impala SS Forum > 91-96 Impala/B-body > Engine Problems/Maintenance
New User? Register - Forgot Password

Reply
 
Thread Tools Display Modes
  #1  
Old 12-17-2009, 12:23 PM
chris_ridin_2z's Avatar
chris_ridin_2z chris_ridin_2z is offline
Senior Member
 
Join Date: Feb 2006
Location: 7 Cities of Virginia
Posts: 242
chris_ridin_2z is an unknown quantity at this point
Send a message via AIM to chris_ridin_2z
Default Heater Core??

Car was running funny...my passenger side floor was soaking wet when there was no rain or water anywhere near my car...im assuming heater core?? About how much should this cost to replace its too cold and im too busy to try and do anything myself..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-17-2009, 02:03 PM
draginwagin draginwagin is offline
Senior Member
 
Join Date: May 2007
Location: Michigan
Posts: 974
draginwagin
Default

Is the pass floor with coolant or water?
__________________
1995 civie DCM Caprice wagon, Imp SS grill, 1LE PVC & swiss, Bilsteins, fbody front bar, Quickor rear bar, UMI lwr rr cntl arms, Silla AL dual core rad, mech fan del, Air Lift bags. PCMperformance tune, AIR delete, Pypes X, Frantz oil & coolant filters, added 7P8, 7Z5, 7L9
1991 OCC all stock, step daughters ride.
Weekend toy-1980 Dodge Mirada, ~ 450HP built 360 --sold
former DD-1992 1A2, L05, stock, (SOLD)
Reply With Quote Quick reply to this message
  #3  
Old 12-17-2009, 02:13 PM
chris_ridin_2z's Avatar
chris_ridin_2z chris_ridin_2z is offline
Senior Member
 
Join Date: Feb 2006
Location: 7 Cities of Virginia
Posts: 242
chris_ridin_2z is an unknown quantity at this point
Send a message via AIM to chris_ridin_2z
Default

at first i thought it was water but it may have been coolant...also at the time when i was actually driving the car there was a coolant smell blowing through the vents whenever i would turn the ac/heat on ....i just made a few calls and was quoted 325 and 400 so its not too bad.
Reply With Quote Quick reply to this message
  #4  
Old 12-17-2009, 03:23 PM
draginwagin draginwagin is offline
Senior Member
 
Join Date: May 2007
Location: Michigan
Posts: 974
draginwagin
Default

If you smell coolant than it's the heater core and not just the condensate drain backing up.
$300-400 is 3 -4 times what it would cost to buy a heater core and do it yourself.
It's a nuisance but not rocket science, (its easier than changing the spark plugs on these cars.)
DO NOT buy a NAPA heater core. They're junk and NAPA's "lifetime warranty" is a f'n fraud.
I got a lifetime warranty heater core from Murreys/O'Reilly's, no probs so far (goin' on 3 years now).
It'll take the better part of an afternoon if it's your 1st time. I can do it in about 45 mins now, but I have mucho experience from changing out leaker NAPA heater cores.
__________________
1995 civie DCM Caprice wagon, Imp SS grill, 1LE PVC & swiss, Bilsteins, fbody front bar, Quickor rear bar, UMI lwr rr cntl arms, Silla AL dual core rad, mech fan del, Air Lift bags. PCMperformance tune, AIR delete, Pypes X, Frantz oil & coolant filters, added 7P8, 7Z5, 7L9
1991 OCC all stock, step daughters ride.
Weekend toy-1980 Dodge Mirada, ~ 450HP built 360 --sold
former DD-1992 1A2, L05, stock, (SOLD)
Reply With Quote Quick reply to this message
  #5  
Old 12-17-2009, 05:22 PM
BCs71's Avatar
BCs71 BCs71 is offline
Senior Member
 
Join Date: Aug 2002
Location: North Chicago Burbs
Posts: 342
BCs71
Default

I did mine two weeks ago and it was easy. Cost $65 in parts at Autozone and now I have hot hot heat.

Do yourself the favor and flush the whole system (or have the shop do it) to make sure all the junk gets cleaned out. The old theory is that while it's possible the heater core "just went bad", the usual reason is that something caused it to leak, possibly chemical reactions in the fluid or years of build-up that has caused an issue. Flushing it will hopefully fix the 'reason', if one exists.
__________________
1996 Caprice LT1 DGGM B4U mostly stock daily driver
1994 Caddy Fleetwood Brougham, lots of show & a little go
1992 Caprice wagon, L05, posi, factory no wood - wife's grocery getter
B.a.D. Bodies of Chicago, RIP
Reply With Quote Quick reply to this message
  #6  
Old 12-17-2009, 08:15 PM
DiGGM95's Avatar
DiGGM95 DiGGM95 is offline
Senior Member
 
Join Date: Jan 2009
Location: chained to a desk somewhere out there
Posts: 731
DiGGM95 is on a distinguished road
Exclamation

Quote:
Originally Posted by chris_ridin_2z View Post
Car was running funny...my passenger side floor was soaking wet when there was no rain or water anywhere near my car...im assuming heater core?? About how much should this cost to replace its too cold and im too busy to try and do anything myself..
Hey Chris, I saw your other post down in the HVAC section. If you are still running without your steam tubes, thats why you keep having cooling system problems. After you get a new heater core, try to get the steam tubes on, to avoid future issues like this, or worse. I know what a pain it can be putting them on with the engine in the car, esp. where that shop plugged your steam holes, but if you keep running without the steam tubes, the heads may end up having to come off anyways, AGAIN. Since we determined that the heads were put back on the opposite sides, the steel plugs that block the holes that are now in the back should be removable with an allen wrench.
__________________

1995 Caprice 9C1
1995 GMC Yukon
2003 **** CVPI
2009 **** CVPI
Youtube

Last edited by DiGGM95; 12-17-2009 at 08:31 PM.
Reply With Quote Quick reply to this message
  #7  
Old 12-17-2009, 08:50 PM
DiGGM95's Avatar
DiGGM95 DiGGM95 is offline
Senior Member
 
Join Date: Jan 2009
Location: chained to a desk somewhere out there
Posts: 731
DiGGM95 is on a distinguished road
Default

^I was editing that post and the stupid server died on me, and now i cant edit. What i was gonna put was, i looked at my original 95 lt1 just awhile ago, and it has plugs in the front of the heads that are removable with a 1/4" drive rachet without a socket on it. Take one of those rachets (they are usualy small), and see if the rachet will connect to the plugs like a socket. With determination, they should come out if the rachet fits.
__________________

1995 Caprice 9C1
1995 GMC Yukon
2003 **** CVPI
2009 **** CVPI
Youtube
Reply With Quote Quick reply to this message
  #8  
Old 12-21-2009, 03:11 PM
chris_ridin_2z's Avatar
chris_ridin_2z chris_ridin_2z is offline
Senior Member
 
Join Date: Feb 2006
Location: 7 Cities of Virginia
Posts: 242
chris_ridin_2z is an unknown quantity at this point
Send a message via AIM to chris_ridin_2z
Default

Took it to the shop and the problem they said was....for one its missing terribly so a tune up is a must (that i already knew) ..i need a new radiator (the old one is clogged and nothing is getting through) ...they said they showed no signs of the heater core (they didnt get any readings for that and the car still blows heat) so with that plus the injectors need to be cleaned or something... they talking about 795.00

@DiGGM95 I also mentioned to them about the steam pipe issue and they said they are going to take a look at it....but if the heads are on the opposite side doesnt that mean im going to have to install the steam pipe backwards as well...how would that work out
Reply With Quote Quick reply to this message
  #9  
Old 12-21-2009, 04:07 PM
DiGGM95's Avatar
DiGGM95 DiGGM95 is offline
Senior Member
 
Join Date: Jan 2009
Location: chained to a desk somewhere out there
Posts: 731
DiGGM95 is on a distinguished road
Default

The steam pipe will go on where it belongs, no matter which way the heads are put on. The heads are IDENTICAL, anything that bolts to them will go back on the side they came off of, no matter which way the heads are put on. There are provisions for the steam pipe on the front and back of each head, just like there are provisions for the temp. sensor in each head. Imho, it would be wacky and downright impossible to try to put the steam pipe on the front, as there is no room for it up there.
__________________

1995 Caprice 9C1
1995 GMC Yukon
2003 **** CVPI
2009 **** CVPI
Youtube
Reply With Quote Quick reply to this message
  #10  
Old 12-26-2009, 12:58 PM
chris_ridin_2z's Avatar
chris_ridin_2z chris_ridin_2z is offline
Senior Member
 
Join Date: Feb 2006
Location: 7 Cities of Virginia
Posts: 242
chris_ridin_2z is an unknown quantity at this point
Send a message via AIM to chris_ridin_2z
Default

oh ok..thanks alot.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:21 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
(c) 2007-2014 Impala SS Forum