Brake lights do NOT work, 3rd brake light does, turn signals work, hazards work - Chevy Impala SS Forum
Impala SS Forum
Go Back   Chevy Impala SS Forum > 91-96 Impala/B-body > Brakes
New User? Register - Forgot Password

Reply
 
Thread Tools Display Modes
  #1  
Old 02-23-2011, 07:49 AM
rabidmadman's Avatar
rabidmadman rabidmadman is offline
Senior Member
 
Join Date: Aug 2010
Location: Sayreville, NJ
Posts: 259
rabidmadman is on a distinguished road
Default Brake lights do NOT work, 3rd brake light does, turn signals work, hazards work

Back in November my stop lights were no longer working while the emergency flashers, turn signals, and 3rd brake light were still working. The turn signal switch turned out to be the problem (at least temporarily). After swapping the turn signal switch in the steering column, the problem went away. Recently, someone pulled up next to me and told me that only my 3rd brake light was working again....so it's safe to assume something is shorting out the switch.

The first thing I did was check all of the bulbs and they are fine. Now I am in the same exact predicament as before..however, this time I am in no rush to replace the turn signal switch since something is causing it to go bad.

What could possibly be wrong with the circuit to damage the turn signal switch? I highly doubt that the brand new ACDELCO switch could have went bad after only 4 months..if not earlier since I was not aware of this problem until recently.

Any help or ideas would be greatly appreciated. Swapping the turn signal switch solved the problem temporarily, but now it will most likely have to be replaced again on top of a wiring troubleshoot.
_________________
__________________
1990 9c1 Chevrolet Caprice

Mods: Rebuilt 350 at 169k bored .010 over (351 ci total displacement), Dual Exhaust with Flowmaster mufflers and a summit high-flow cat, 700R4 rebuilt with strengthened high gear clutch pack and a new torque converter.


SOLD:
1988 Chevrolet Caprice Classic
305 stock in every way possible.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-23-2011, 09:31 AM
Goldmaster's Avatar
Goldmaster Goldmaster is offline
Moderator
 
Join Date: Nov 2006
Location: Warren, MI
Posts: 9,404
Goldmaster is on a distinguished road
Default

What about the brake light switch that's connected to the brake pedal? Maybe that went bad?
Reply With Quote Quick reply to this message
  #3  
Old 02-23-2011, 11:34 AM
rabidmadman's Avatar
rabidmadman rabidmadman is offline
Senior Member
 
Join Date: Aug 2010
Location: Sayreville, NJ
Posts: 259
rabidmadman is on a distinguished road
Default

If the brake switch was bad, the 3rd brake light would not work. It's primarily a problem with the turn signal switch since the hazards and stop lights both are on the same circuit. I have no idea what is causing this problem. After replacing the switch in the column, the brake lights worked beautifully for some time until recently.
__________________
1990 9c1 Chevrolet Caprice

Mods: Rebuilt 350 at 169k bored .010 over (351 ci total displacement), Dual Exhaust with Flowmaster mufflers and a summit high-flow cat, 700R4 rebuilt with strengthened high gear clutch pack and a new torque converter.


SOLD:
1988 Chevrolet Caprice Classic
305 stock in every way possible.
Reply With Quote Quick reply to this message
  #4  
Old 02-23-2011, 12:59 PM
bob441's Avatar
bob441 bob441 is offline
Senior Member
 
Join Date: Jul 2006
Location: kentucky
Posts: 412
bob441
Default

I THINK there are 2 brake light switches the second switch that operates the 3rd light also operates the cruise and if the 3rd bulb is out the cruise won't work
__________________
1996 Caprice leather 3.73's driftwood met
1994 Fleetwood ~For sale~ CHEAP
1988 Trans Am AA8 Nothcback 5.7 TPI~ For sale ~
Reply With Quote Quick reply to this message
  #5  
Old 02-23-2011, 01:16 PM
rabidmadman's Avatar
rabidmadman rabidmadman is offline
Senior Member
 
Join Date: Aug 2010
Location: Sayreville, NJ
Posts: 259
rabidmadman is on a distinguished road
Default

I'm going to swap out the brake switch and see what happens. This car does not have cruise. Thanks for the help guys.
__________________
1990 9c1 Chevrolet Caprice

Mods: Rebuilt 350 at 169k bored .010 over (351 ci total displacement), Dual Exhaust with Flowmaster mufflers and a summit high-flow cat, 700R4 rebuilt with strengthened high gear clutch pack and a new torque converter.


SOLD:
1988 Chevrolet Caprice Classic
305 stock in every way possible.
Reply With Quote Quick reply to this message
  #6  
Old 02-23-2011, 02:03 PM
Interceptor9C1 Interceptor9C1 is offline
Senior Member
 
Join Date: Jan 2005
Location: NJ
Posts: 867
Interceptor9C1 is an unknown quantity at this point
Send a message via AIM to Interceptor9C1
Default

yeah, the third brake light works with a different switch than the regular brake lights
__________________
96 Caprice 9C1 LT1 3.73 posi, Spohn sways, IMR lowers, fully poly, KYB, FIPK, air foil, TB bypass, 160* T-stat, airpump delete, PCM tune, edge 2600, dynomax pipes/spintech prostreets, Z28 cluster, 12 way Bonnies
Reply With Quote Quick reply to this message
  #7  
Old 02-23-2011, 02:19 PM
Mr pogo's Avatar
Mr pogo Mr pogo is offline
Senior Member
 
Join Date: Oct 2003
Location: SoCal
Posts: 5,978
Mr pogo is on a distinguished road
Default

Quote:
Originally Posted by rabidmadman View Post
If the brake switch was bad, the 3rd brake light would not work. It's primarily a problem with the turn signal switch since the hazards and stop lights both are on the same circuit. I have no idea what is causing this problem. After replacing the switch in the column, the brake lights worked beautifully for some time until recently.
did you swap out brake light bulbs to higher wattage?
you could pull all the bulbs then ohm out the circuit to see if its still got continuity to ground altho an intermittant short might not show up.

might take apart the old ts switch after replacing it and see what the slider contacts look like.
if they are burnt and melted the plastic around them then its excessive amperage, theres also always a chance it was just a defective switch and nothing else wrong.
__________________
evil T-47 seatbelt bolts and cutdown ZQ8 bumpstops, Kore3 front brakes, TB bypass, Dynotech DS, F-body EGR, Meziere WP, Comp Cams 1.6RR/CM springs, trans by Moi Industries, Yank 3600, Earls trans cooler/rad cooler delete/Derale t-stat, RAISS, SLP headers, SLP injectors, pypes X-pipe/magnaflows, Borgeson shaft, Hotchkis springs, PPM front stuff, Metco rear arms, Clear Image DS loop/trans crossmember, 3.73s, eaton posi, Hypertech for smog \"[<img BH tuned PCM
Reply With Quote Quick reply to this message
  #8  
Old 02-23-2011, 05:44 PM
bob441's Avatar
bob441 bob441 is offline
Senior Member
 
Join Date: Jul 2006
Location: kentucky
Posts: 412
bob441
Default

also look and see if there is trailer plug on the car look up in the driverside fender on top where the trunk lid closes after market plugs plug in there
__________________
1996 Caprice leather 3.73's driftwood met
1994 Fleetwood ~For sale~ CHEAP
1988 Trans Am AA8 Nothcback 5.7 TPI~ For sale ~
Reply With Quote Quick reply to this message
  #9  
Old 02-23-2011, 07:18 PM
BandGbodies's Avatar
BandGbodies BandGbodies is offline
Senior Member
 
Join Date: Feb 2008
Location: Kalamazoo, MI
Posts: 362
BandGbodies is on a distinguished road
Default

You're having the same issue as before. The problem is wiring harness in the column for the turn signal switch. This a a very common problem on GM columns on all models. If you get down under the dash, you will find the white wire on the column side of the plug broken just after the plug. It is the wire on the "top" end of the plug, closest to the driver. What causes the problem is the that the wire is bent too sharply, which after a while causes the wire to break. You can try to pull the pin out of the connector, strip the wire and try to get it back in the plug, but often there isn't enough wire to do that. Usually, I've ended up having to replace the turn signal switch in the column. Not to bad to replace, last one took me about 2 hours to do. The biggest pain is snaking the wires down the column. If you have any questions, just ask.
__________________
Andy

96 Caprice Classic
L99 w/ K&N Cold Air Kit, Home Base Delete w/ 1LE elbow, Impala SS springs and sway bars, MSD coil & wires, filled rear decklid courtesy of Dr. Sinister, 6-way Bonneville front buckets, Jegs catback dual exhaust, working on an Olds Bravada console.
263,000 Miles and counting -now sold 9/10/12

Last edited by BandGbodies; 02-23-2011 at 07:21 PM.
Reply With Quote Quick reply to this message
  #10  
Old 02-26-2011, 07:50 AM
rabidmadman's Avatar
rabidmadman rabidmadman is offline
Senior Member
 
Join Date: Aug 2010
Location: Sayreville, NJ
Posts: 259
rabidmadman is on a distinguished road
Default

Hey, but the turn signal switch in the car was replaced in November. Do you really think the brand new switch could have gone bad after 4 months due to a bent wire? I've checked the brake light switch and the harnesses for the tail lights/3rd brake light look fine.
__________________
1990 9c1 Chevrolet Caprice

Mods: Rebuilt 350 at 169k bored .010 over (351 ci total displacement), Dual Exhaust with Flowmaster mufflers and a summit high-flow cat, 700R4 rebuilt with strengthened high gear clutch pack and a new torque converter.


SOLD:
1988 Chevrolet Caprice Classic
305 stock in every way possible.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:04 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
(c) 2007-2014 Impala SS Forum