interior lights not working.... - Chevrolet Impala SS Forum : Chevy Impala SS Forums
Impala SS Forum
Go Back   Chevrolet Impala SS Forum : Chevy Impala SS Forums > 91 thru 96 B-body Model Specific > Wagons
New User? Register - Forgot Password

Reply
 
Thread Tools Display Modes
  #1  
Old 02-15-2012, 02:48 AM
O. Bradley's Avatar
O. Bradley O. Bradley is offline
Senior Member
 
Join Date: Apr 2007
Location: Antioch, CA
Posts: 113
O. Bradley
Send a message via Yahoo to O. Bradley
Default interior lights not working....

My interior lights do not work....... I see my digital speedometer during the day but at night that is all i see as well...... i tried the fuse but when i put it in.. there is a quick spark then the fuse cracks... does anyone know what i can possibly do to troubleshoot?
__________________
Leaders come and leaders go....but ONE thing remains the same......and that is ME!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-15-2012, 08:25 AM
GoldSSWagon's Avatar
GoldSSWagon GoldSSWagon is offline
Senior Member
 
Join Date: Oct 2002
Location: Albuquerque
Posts: 1,912
GoldSSWagon is an unknown quantity at this point
Default

Interior lights or dash lights. Two different circuits....
__________________
1995 Gold Caprice Wagon
1991 White Caprice Wagon
1991 Olds Custom Cruiser Wagon Sold
1995 RMW under construction
2004 Impala SS
2012 Chevy Terrain SL2
1974 BD-5T WIP
Reply With Quote Quick reply to this message
  #3  
Old 02-15-2012, 08:49 AM
Gkeepa Gkeepa is offline
Member
 
Join Date: Dec 2011
Location: Tempe, AZ
Posts: 78
Gkeepa is on a distinguished road
Default

Quote:
Originally Posted by O. Bradley View Post
My interior lights do not work....... I see my digital speedometer during the day but at night that is all i see as well...... i tried the fuse but when i put it in.. there is a quick spark then the fuse cracks... does anyone know what i can possibly do to troubleshoot?
Can you rotate the inst. cluster illumination dimmer wheel(next to the head light switch on my '94--don't know if it's the same for all years of wagon)all the way so that it turns on your dome light? If that works, then (if your vehicle is equipped with one), it's prolly the chime module that's bad. Does your door chime work? If your chime doesn't work, AND your lights don't come on when you open the doors, BUT they(the light)come on when you rotate that dimmer wheel, then that's most likely the cause. "They" don't make them any more. If you find one, buy another for me, and I'll pay you.

The module is plugged into a panel on the firewall/floor board-ish area under the steering column. Mine was green(except for the black soot streaks that leaked out and clung to the side of the housing when it fried).

As for your fuses blowing...I'm all thumbs when it comes to 'lectricity and sir-cuts and what-not. Good luck on THAT one.
__________________
Karl Gant
1994 Caprice Classic Wagon
Tempe, AZ
Reply With Quote Quick reply to this message
  #4  
Old 02-16-2012, 03:10 AM
O. Bradley's Avatar
O. Bradley O. Bradley is offline
Senior Member
 
Join Date: Apr 2007
Location: Antioch, CA
Posts: 113
O. Bradley
Send a message via Yahoo to O. Bradley
Default

Funny you asked that... the door chime comes on when i open the door but the dome light doesnt even when i rotate the lights on...! I failed to mention that mu door locks dont operate..... i replaced the fuse and they worked for one unlock then the fuse pops.... that was the situation..... the cluster lights work but i thing something doesnt come on... ill check when i get home!
__________________
Leaders come and leaders go....but ONE thing remains the same......and that is ME!!
Reply With Quote Quick reply to this message
  #5  
Old 02-16-2012, 01:46 PM
Gkeepa Gkeepa is offline
Member
 
Join Date: Dec 2011
Location: Tempe, AZ
Posts: 78
Gkeepa is on a distinguished road
Default

Quote:
Originally Posted by O. Bradley View Post
Funny you asked that... the door chime comes on when i open the door but the dome light doesnt even when i rotate the lights on...! I failed to mention that mu door locks dont operate..... i replaced the fuse and they worked for one unlock then the fuse pops.... that was the situation..... the cluster lights work but i thing something doesnt come on... ill check when i get home!

Uh-oh. Then I wouldn't have the slightest clue...sorry.
__________________
Karl Gant
1994 Caprice Classic Wagon
Tempe, AZ
Reply With Quote Quick reply to this message
  #6  
Old 02-16-2012, 08:06 PM
Fred Kiehl's Avatar
Fred Kiehl Fred Kiehl is online now
Senior Member
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 8,012
Fred Kiehl is on a distinguished road
Default

Your dimmer switch may be fried. It is not uncommon.

The door lock fuse could be a shorted lock motor, or the lock relay may be shorted. The lock relay is behind the driver's side kick panel, behind the E-brake. You could even have a bare wire touching something. The lock motors use the circuit breaker, and the relay uses the fuse.
__________________
1991 OCC upgraded LO5, LT1 cam, 46mm TBI, bored intake manifold, wrapped headers, true duals w/Flowmasters, 3.23 posi, flash to pass, drop spindles & springs, custom fender skirts, stainless full moons, Recaros, Blazer console, Nardi/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, SS wheels. DEH P77DH
For a parts list, check Plenty of good parts
Reply With Quote Quick reply to this message
  #7  
Old 02-21-2012, 02:05 AM
O. Bradley's Avatar
O. Bradley O. Bradley is offline
Senior Member
 
Join Date: Apr 2007
Location: Antioch, CA
Posts: 113
O. Bradley
Send a message via Yahoo to O. Bradley
Default

Thanks sooo much Mr. fred... u r the MAN!!
__________________
Leaders come and leaders go....but ONE thing remains the same......and that is ME!!
Reply With Quote Quick reply to this message
  #8  
Old 08-24-2012, 06:48 AM
95blackcherryss's Avatar
95blackcherryss 95blackcherryss is offline
Member
 
Join Date: May 2011
Location: South Texas
Posts: 61
95blackcherryss is on a distinguished road
Default

Help , mine is having a similar problem my dash light fuse pops as soon as i put a fuse in the int dim., i tried everything ya mentioned in previous threads and all works as should
Reply With Quote Quick reply to this message
  #9  
Old 08-24-2012, 12:28 PM
Fred Kiehl's Avatar
Fred Kiehl Fred Kiehl is online now
Senior Member
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 8,012
Fred Kiehl is on a distinguished road
Default

You have a short (for once it is actually a short, not an open circuit). You are probably going to have to troubleshoot with a VOM. The other option is to unplug parts in the system to isolate the short. Start at one extreme end, and work your way to the other. You need a wiring diagram. If you do not have an FSM, the Haynes Manual has a wiring diagram in the back that will suffice. The Haynes Manual will not give you the location of the part, but will supply the color code, and show the parts in the circuit.


Quote:
Originally Posted by 95blackcherryss View Post
Help , mine is having a similar problem my dash light fuse pops as soon as i put a fuse in the int dim., i tried everything ya mentioned in previous threads and all works as should
__________________
1991 OCC upgraded LO5, LT1 cam, 46mm TBI, bored intake manifold, wrapped headers, true duals w/Flowmasters, 3.23 posi, flash to pass, drop spindles & springs, custom fender skirts, stainless full moons, Recaros, Blazer console, Nardi/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, SS wheels. DEH P77DH
For a parts list, check Plenty of good parts
Reply With Quote Quick reply to this message
  #10  
Old 08-24-2012, 01:33 PM
Phantom59's Avatar
Phantom59 Phantom59 is offline
Senior Member
 
Join Date: Nov 2011
Posts: 101
Phantom59 is on a distinguished road
Default

I also had a problem with this fuse blowing and making the gate ajar light come on. After about 4 hours of tracing wires and schematics in the manual I found a smashed wire behind the grab handle LR door.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevrolet Impala SS Forum : Chevy Impala SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:45 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
(c) 2007-2011 Impala SS Forum