Shuts off - then will restart. - Chevy Impala SS Forum
Impala SS Forum
Go Back   Chevy Impala SS Forum > 91-96 Impala/B-body > Engine Problems/Maintenance
New User? Register - Forgot Password

Reply
 
Thread Tools Display Modes
  #1  
Old 08-22-2012, 11:01 AM
VF1000R's Avatar
VF1000R VF1000R is offline
Senior Member
 
Join Date: Dec 2005
Location: Mobile, Alabama
Posts: 458
VF1000R
Default Shuts off - then will restart.

I'm 10 miles into a 20 mile drive to work.


running 65 on a flat highway.

Engine just shuts off.


Coast to stop.


turn key off , wait 30 seconds , turn key on and then restart.


Less than 1 year old MSD New OPTI. Fairly new ICM. No check lights and no DTC's.

and returned Ignition to stock , got rid of the Mallory 685.

any thoughts ?
__________________
95 Impala , 96 Motor/PCM, Ported/Polished Heads - 2.02's / 1.6's, Comp XFI 468 cam, Mike Harris FL Headers, 3.0" Duals, 3.73's with Auburn Posi, CAI and 3.5" MAF, BH Tune, 150 Shot, Custom Performance Tranny with a Vigilante 3100 TC, Dual Snorkel Glass Hood and Front Bumper, DGGM. 2009 Pontiac G8GT

Last edited by VF1000R; 08-22-2012 at 11:03 AM. Reason: add
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-22-2012, 12:15 PM
kiddpitt kiddpitt is offline
Senior Member
 
Join Date: Jan 2010
Location: Pottstown, PA
Posts: 850
kiddpitt is on a distinguished road
Default

It could be so many different things. Read throught the many threads on here & start making your list of things to check.

fuel pressure, icm, coil, & opti harness just to name a few

And yes, I saw you have a fairly new ICM. Did you use the heatsink compound with it? If not, I would start there.
__________________
1995 Roadmaster Wagon
1972 Ford LGT 100
Reply With Quote Quick reply to this message
  #3  
Old 08-22-2012, 01:29 PM
SimplyTheBeSS's Avatar
SimplyTheBeSS SimplyTheBeSS is offline
Senior Member
 
Join Date: Aug 2010
Location: St. Louis, MO
Posts: 2,374
SimplyTheBeSS is on a distinguished road
Default

Probably Spark or Gas related. If it was me.

1. Get a fuel pressure gauge and check your line pressure. See if you start seeing it drop off etc...

2. Clean all your ground connections (can't hurt) especially by the battery

3. Change fuel filter if it has been awhile (can't hurt)

4. Put in a can of Seafoam or approved equal (can't hurt)

5. Check to make sure your Opti is dry and that the Waterpump hasn't been leaking on it.
__________________
1994 SS - GRAIL Webmaster, St. Louis, MO
View our Tech/Guide page for everything from your basic oil change to Manual transmission swaps!

Reply With Quote Quick reply to this message
  #4  
Old 08-22-2012, 06:28 PM
impalassdude's Avatar
impalassdude impalassdude is offline
Senior Member
 
Join Date: Oct 2003
Location: sunrise,fl
Posts: 4,094
impalassdude is an unknown quantity at this point
Send a message via AIM to impalassdude
Default

next time it dies.you shouldn't have any fuel pressure if its the ICM.also it usally take several min to cool down. then it will restart.the opti will give the same signs but start right back up.if you can have it scanned and see if your getting a weak signal from the opti.if so its ether your new opti or the cable going to it.
__________________
http://www.youtube.com/watch?v=GRqsOvpSxA4
President of SoFASST.com
05-06 1st place 94 class nationals
05 3rd place sound off
06 3rd place autocross
also as seen on the ITT commercial
95 caprice wagon impala clone
Reply With Quote Quick reply to this message
  #5  
Old 09-05-2012, 09:14 PM
VF1000R's Avatar
VF1000R VF1000R is offline
Senior Member
 
Join Date: Dec 2005
Location: Mobile, Alabama
Posts: 458
VF1000R
Default

None of the above suggestions have proven to be an issue.


It almost has to be electrical.

The MSD opti has abuilt in cable that eliminares the old plug in cable issue.


If it was fuel , the car would at least run rough for a few seconds,


This is happening like the key was turned off.

All engine grounds were repaired last year , after it was found several leads were broken at the cylinder head.

so , the search goes on.
__________________
95 Impala , 96 Motor/PCM, Ported/Polished Heads - 2.02's / 1.6's, Comp XFI 468 cam, Mike Harris FL Headers, 3.0" Duals, 3.73's with Auburn Posi, CAI and 3.5" MAF, BH Tune, 150 Shot, Custom Performance Tranny with a Vigilante 3100 TC, Dual Snorkel Glass Hood and Front Bumper, DGGM. 2009 Pontiac G8GT
Reply With Quote Quick reply to this message
  #6  
Old 09-06-2012, 08:39 AM
55belairgasser 55belairgasser is offline
Senior Member
 
Join Date: Jan 2008
Location: Parrish, Fl.
Posts: 796
55belairgasser is on a distinguished road
Default

Mine is doing the same thing. I put new CIA headers on and new 3" pipes all the way back and got rid of the cats. I had PCM reprogramed without the EGR and not using the rear O2's. I can drive the car and not have any problems for a couple of days and then...it just turns off. I don't have any stutter it just cuts out. If I leave it for a min. or two it restarts and runs fine. I have checked the fuel and it reads fine at both idel and in gear. The plugs are new and so are the wires. I have not checked the grounds yet. If I find it I will let you know. Good luck VF1000R.
__________________
Lance Hayworth
1996 Impala SS-Black, Proforged 1" lowered Auto X rear springs & Rustic Racing #750 frt., QA1 shocks all the way around, Hotckis sway bars, UMI Upper ext. control arms and BMR lowers, Poly body bushings, Dick Miller brace, 52 mm T.B., Promag 1.6 roller rockers, K&N Fipk, Quad 1 Headers and 3" pipes w/ Spintech's, Delteq 4 coil pack, MSD Opti, PCMPerformance tune, HID 50 watt frt. lights, Suncoast hood, ISSCA & GOFASST member
1955 Chevy Belair Sedan(being worked on)
Reply With Quote Quick reply to this message
  #7  
Old 09-06-2012, 08:59 AM
kiddpitt kiddpitt is offline
Senior Member
 
Join Date: Jan 2010
Location: Pottstown, PA
Posts: 850
kiddpitt is on a distinguished road
Default

Quote:
Originally Posted by 55belairgasser View Post
I can drive the car and not have any problems for a couple of days and then...it just turns off. I don't have any stutter it just cuts out. If I leave it for a min. or two it restarts and runs fine.
In June, I had the same symptom, shutting off with no stumble. Troubleshooting led me to the ICM, but I also replaced the coil at the same time. If I remember what I read on here at the time, a bad coil can fry a new ICM fairly quickly.
__________________
1995 Roadmaster Wagon
1972 Ford LGT 100
Reply With Quote Quick reply to this message
  #8  
Old 09-06-2012, 09:26 AM
atlantadan atlantadan is offline
Senior Member
 
Join Date: Oct 2011
Location: Atlanta
Posts: 106
atlantadan is on a distinguished road
Default

Ignition coil or MAF.

I know that there are those on here that say that your car will run with the MAF disconnected, but mine won't - and wouldn't do so even with the stock engine and ECU in perfect running condition. I think it is an issue specific to the 96 engine/ECU.

I JUST had this same issue last week and posted a thread about it. Replaced the coil and MAF and I was back on the road. I see that you've replaced the coil recently, so change out your MAF and see what happens
__________________

1996 Caprice, a work in progress..
Reply With Quote Quick reply to this message
  #9  
Old 09-07-2012, 09:46 PM
VF1000R's Avatar
VF1000R VF1000R is offline
Senior Member
 
Join Date: Dec 2005
Location: Mobile, Alabama
Posts: 458
VF1000R
Default

Quote:
Originally Posted by atlantadan View Post
Ignition coil or MAF.

I know that there are those on here that say that your car will run with the MAF disconnected, but mine won't - and wouldn't do so even with the stock engine and ECU in perfect running condition. I think it is an issue specific to the 96 engine/ECU.

I JUST had this same issue last week and posted a thread about it. Replaced the coil and MAF and I was back on the road. I see that you've replaced the coil recently, so change out your MAF and see what happens
Ok, Anybody got a 3" F-Body MAF laying around ?
__________________
95 Impala , 96 Motor/PCM, Ported/Polished Heads - 2.02's / 1.6's, Comp XFI 468 cam, Mike Harris FL Headers, 3.0" Duals, 3.73's with Auburn Posi, CAI and 3.5" MAF, BH Tune, 150 Shot, Custom Performance Tranny with a Vigilante 3100 TC, Dual Snorkel Glass Hood and Front Bumper, DGGM. 2009 Pontiac G8GT
Reply With Quote Quick reply to this message
  #10  
Old 09-10-2012, 09:23 AM
55belairgasser 55belairgasser is offline
Senior Member
 
Join Date: Jan 2008
Location: Parrish, Fl.
Posts: 796
55belairgasser is on a distinguished road
Default

VF1000R, let me know if the MAF clears it up. I have another two used stock ones around my shop somewhere, and a 3" when I am ready for it. I have the 4 coil Northstar setup and have already switched them around twice so I know it should not be them. I will try the ICM also. Thanks for the input. - Lance
__________________
Lance Hayworth
1996 Impala SS-Black, Proforged 1" lowered Auto X rear springs & Rustic Racing #750 frt., QA1 shocks all the way around, Hotckis sway bars, UMI Upper ext. control arms and BMR lowers, Poly body bushings, Dick Miller brace, 52 mm T.B., Promag 1.6 roller rockers, K&N Fipk, Quad 1 Headers and 3" pipes w/ Spintech's, Delteq 4 coil pack, MSD Opti, PCMPerformance tune, HID 50 watt frt. lights, Suncoast hood, ISSCA & GOFASST member
1955 Chevy Belair Sedan(being worked on)
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:15 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
(c) 2007-2014 Impala SS Forum