Chevy Impala SS Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter · #1 ·
cwm7is there a diffenerence in throttle response or spark to the plug.....bc. it says to use .50 gap on my lt1 ......but the guy at the auto store sold me .60 gap......is that worse???????? what would you consideer...or should i have no problems with teh .60 gaps???
 

·
Premium Member
Joined
·
9,190 Posts
cwm7is there a diffenerence in throttle response or spark to the plug.....bc. it says to use .50 gap on my lt1 ......but the guy at the auto store sold me .60 gap......is that worse???????? what would you consideer...or should i have no problems with teh .60 gaps???
its .50

thanks
 

·
Registered
Joined
·
1,461 Posts
They told me the same thing at Advance when I bought plugs for my LT1. My book says .050, and the sticker under the hood says .050, so thats what I went with.
 

·
Registered
Joined
·
981 Posts
ok, can you re-gap the spark plug on certain platinum plugs???.
Depends on the plug, I suppose. I just installed NGK platinum plugs. They were gapped at around .58 when I got them. I just re-gapped them to .50 like I would normally do.
 

·
Registered
Joined
·
1,233 Posts
Depends on the plug, I suppose. I just installed NGK platinum plugs. They were gapped at around .58 when I got them. I just re-gapped them to .50 like I would normally do.
I still have NGK iridiums waiting to be installed. They are all pregapped at 0.0585" .
 

·
Registered
Joined
·
1 Posts
Need help

Ok I just bought my dream car its a 95 impala ss its real did home work I just bought new spark plugs and wires I put them on there and now I retreat it now it haves a ruff idle its so bad when you r at a stop light u can see the dash dim I bought acdelco spark plugs and wires and the spark plugs where gap 60+ so I put them to 50 help me
 

·
Registered
Joined
·
5,693 Posts
Double check for correct wire routing, sounds like you might have crossed a plug wire. make sure the wires are on TIGHT, you should hear them click twice.
 

·
Banned
Joined
·
407 Posts
Yeah plugs should be gapped at .50... IMO... I only use ac delco. I think mines were gapped a little over .60 and I just gapped them at .50. Car runs good. Btw, u should change your opti when you're changing everything else, might as well. Unless u dont want to
 
1 - 10 of 10 Posts
Top