Chevy Impala SS Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
472 Posts
Discussion Starter · #1 ·
Summer is over. My best to date this year, as stated was an 11.59.
I posted this info on another thread a while ago, answering what my 60' time was for this pass and it was a 1.63.
As some of you had pointed out, my motor must be doing some big end make up for my 60' time being what it is.
I currently have an Edge Racing torque converter set at 3000 stall. I am thinking my first over the winter mod to be raising the stall speed. I have contacted Andre at Edge and he told me it would be no problem to send my converter back and he can reset it to a higher stall for a very reasonable price.
I am using a Comp Cam 503 and I do have 4:10 gears. I am thinking in the area of 3500-3800 stall.
I am hoping this will improve my 60' times.
Any thoughts or suggestions?
Regards,
Matt.
 

·
Registered
Joined
·
6,751 Posts
Can you post the entire run? time and mph at all measurement points of the track?
 

·
Registered
Joined
·
472 Posts
Discussion Starter · #3 ·
60' .....1.639
330.....4.772
1/8.....7.774
MPH....93.66
1000...9.680
MPH....116.68

Hope this helps.
Regards,
Matt.
 

·
Premium Member
Joined
·
1,056 Posts
Summer is over. My best to date this year, as stated was an 11.59.
I posted this info on another thread a while ago, answering what my 60' time was for this pass and it was a 1.63.
As some of you had pointed out, my motor must be doing some big end make up for my 60' time being what it is.
I currently have an Edge Racing torque converter set at 3000 stall. I am thinking my first over the winter mod to be raising the stall speed. I have contacted Andre at Edge and he told me it would be no problem to send my converter back and he can reset it to a higher stall for a very reasonable price.
I am using a Comp Cam 503 and I do have 4:10 gears. I am thinking in the area of 3500-3800 stall.
I am hoping this will improve my 60' times.
Any thoughts or suggestions?
Regards,
Matt.

Andre at Edge is awesome.. I was in the middle of a transmission swap, he made and overnighted me a 3700 stall.
 

·
Registered
Joined
·
6,751 Posts
60' .....1.639
330.....4.772
1/8.....7.774
MPH....93.66
1000...9.680
MPH....116.68

Hope this helps.
Regards,
Matt.
If you look at the dynamic ET page, most of the guys running 11.50's at 120 in the quarter and 93 mph in the eighth are turning 7.40's at the eighth mile. So your problem is in the first half of the track - but you already knew that.

I think you're on the right track re-stalling the converter. Comp cams tend to sacrifice low end for high end horsepower; and again, looking at the ET page, most guys running low 11's in your mph range have converters stalled around 4000.

Your trans could also be slipping on the 1-2 shift - how long has it been since your last transmission build?

I also had a problem with my tires slipping around my rims. Had to put screws in my rims to stop it.
 

·
Registered
Joined
·
472 Posts
Discussion Starter · #7 ·
Thanks for the input.
My tranny was rebuilt not too long ago. It was rebuilt with some decent parts, Beast sunshell casing, .500 boost valve, new clutch packs, Superior servos, lighter accumulator spring, etc.
The tranny seems to be doing its job. I agree with what you are saying. I am starting to think about 3800 stall to get my bottom end up.
I should also be thinking about my tires slipping on the rims. I had them balanced, but after a weekend competition, they are out of balance pretty good. I am sure the tires are slipping on the rims a little.
 

·
Registered
Joined
·
6,751 Posts
Well, good luck with it. You've got a hell of a car!
 

·
Premium Member
Joined
·
3,564 Posts
Your car is definitely back "back halfing" after the eigth mile. I would data log a few runs to see how effecient that TC is. It looks tighter on only one half of your run.

That is an impressive ET with that 60'. Keep working on it. You have a little more ET in it.
 
1 - 10 of 10 Posts
Top