Chevy Impala SS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
We have a 1965 Impala SS that is having transmission fluid spewing out the filler hole when you cut the engine off, we had the transmission rebuilt to start with and started having this trouble after that, we took the transmission back out and took it back to the transmission shop, he said they put air on it and they heard it pop, like it blew the obstruction out, he did not tear the transmission down after he heard that, we put the transmission back in, thought everything was ok, and now the same problem again, what else could it be, HELP, very aggravating, anybody have any ideas?
 

·
Registered
Joined
·
5,772 Posts
What did the transmission shop blow out with air? Did they check the vent/breather hose? If this is blocked, it can cause problems like this. I'm no transmission expert though. I'm sure you will get some more suggestions here, but just and FYI this forum is mainly for 91-96 B-body cars/Impalas. But we still got love for the old school stuff. Post some pics if you can. My brother had a 65 back in the day. Always loved that body style. :)


You could try impalaforums.com it covers the older models.
 

·
Registered
Joined
·
2,703 Posts
Or a TH350 or TH400. And what engine?

Those old GM trans are everywhere, with great parts availability, and cheaper than new stuff.

What do you have?

And welcome to the forum!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top