Chevy Impala SS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
Continuing the restoring of my late Dad's Caprice .

No heat ! :-(

The lower horizontal lever on the Climate Control Center goes from cold to hot . Nothing happens . I re-attached the left end of the cable to the Climate Control Center . Still nothing .

My understanding is the other end of the cable operates a blend door , inside the heater ?

I need info , photos and / or pdf's , please .

Thanks ,
Wyr
God bless
 

·
Registered
Joined
·
2,058 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #3
I think I need to investigate the mechanical cable from the Heat / Cool Selector to the round assembly on the plastic housing ?

Thank you ! :)

God bless
Wyr



 

·
Registered
Joined
·
40 Posts
Discussion Starter #4
1991 Caprice Heater

It turns out my heater - A/C " box " looks a little different than the picture , But the picture was still very helpful . :)



Thanks





Pulled off some of the plastic lower dash panels and the ash tray / cup holder off . Located the mechanical cable that operates the cold - hot blend door . Re-attached the cable and now I can hear the blend door flopping about , when I move the control lever on the Climate Control Center !



Praise the Lord ! :)


I also tried to replace the black plastic vacuum operated hot water / coolant valve . I tested both the new & the old valve & looking in one of the heater hose ports . I could see the inside part of the valve moving when I applied vacuum . Unfortunately , I broke the new , plastic valve . It was getting late , so I re-installed the old valve .


No joy ! :-(



I have been having vacuum problems . I had to run a new vacuum line to the controls , to get the system to change from each of the heat , cool , vent , defrost functions . I also ran a temporary new vacuum line to the water valve . This did not seem to help . No hot / warm air . :-(


Then it occurred to me that the logic of the controls may be the opposite to what I had guessed . I removed the temporary vacuum source from the water valve & I started receiving warm air from the vents !


Praise the Lord ! :)


The air was not hot . But it was warm , a HUGE improvement !


I do not know , it may never get hot ? And I may still need to work on the vacuum issues , when it gets warm enough to no longer need heat ?


But that is something to address , at a latter date .


God bless
Wyr
 

·
Registered
Joined
·
40 Posts
Discussion Starter #5
Checked & the water valve responds to vacuum . AT full hot , zero vacuum . Full cold , full vacuum .

God bless
Wyr
 
1 - 5 of 5 Posts
Top