Chevy Impala SS Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
got my impala ss motor unsiezed.

got it to run i drove the car to the end of the driveway and it cut off.

did some tinkering. it has fuel pressure. has spark. obviously getting air

now the car wont start. it will turn over and will start with starting fluid. we even took the brake booster hose off the brake booster. and bottle fed the engine gasoline. and it will crank and run. as long as someone is dripping gas into the brake booster line that goes to the intake

my friends dad put a stethescope on the fuel injectors and said they werent firing. i put a screwdriver up to an injector as my friend tried to crank it. and they arent clicking/firing

both fuses are fine

we even swapped the fuel injectors with a set from a 1997 z28 camaro. still nothing. what now?
 

·
Premium Member
Joined
·
6,358 Posts
check fuel pressure and any fault codes if fp is ok.
 

·
Premium Member
Joined
·
4,753 Posts
I think there is a "fuel/Inj" fuse in the underhood fuse box.
Check all fuses.
Should have 12 volts on both injector wires with key on.
 

·
Registered
Joined
·
3,913 Posts
What were the pressures you observed during the fuel pressure test?

Pick an injector plug and unplug it. With a conventional test light, not an LED one, probe the connector and check for power on the pink wire. If all good, move the ground of the light to the positive cable of the battery or the auxillary power post and have someone crank the motor while you probe the other wire. It should blink. this would indicate pulse. If not, we have some pinpoint tests to run with a dvom and a scan tool if you have it.

Chris
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
digging in

went to check the trouble codes with an OBDII scanner and theres a connection problem. scanner isn't picking up the OBD port.

fuel injectors are getting a 12 volt constant with key on, but not pulsing when I try to crank it

fuel pressure is good

fuses in fuse box are good


I have a feeling since its been sitting so long I bet some rats chewed up some wires somewhere -___- I really hate dealing with wiring/wire tracing issues.
 

·
Registered
Joined
·
9,682 Posts
What is the actual fuel pressure reading you are getting? Did you check it with a guage or just see if the line was pressurized? Pressure on the line doesn't always mean the pressure is good. Should be about 40PSI with key on engine off.
 

·
Registered
Joined
·
1 Posts
digging in

went to check the trouble codes with an OBDII scanner and theres a connection problem. scanner isn't picking up the OBD port.

fuel injectors are getting a 12 volt constant with key on, but not pulsing when I try to crank it

fuel pressure is good

fuses in fuse box are good


I have a feeling since its been sitting so long I bet some rats chewed up some wires somewhere -___- I really hate dealing with wiring/wire tracing issues.
I have the same problem. Did you fix it?
 
1 - 8 of 8 Posts
Top