Chevy Impala SS Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
617 Posts
Discussion Starter · #1 ·
I figured my first gear is probably messed up. Whenever I press on it from a slow speed or a stop it feels like it struggles to get going. Also it doesn't want to peel tires so that gives me a hint that the transmission has something wrong.
 

·
Registered
Joined
·
617 Posts
Discussion Starter · #3 · (Edited)
struggle as in it's missing a bunch of horses or it doesn't feel powerful like it should be. I can't even peel tires and all the fluids including transmission and the filters oil and fuel have been changed within the past month. someone said check the fuel pressure or the fuel injector fuses. again this is felt more when trying to take off fast or burn rubber. on the highway it will pick up fine
 

·
Registered
Joined
·
617 Posts
Discussion Starter · #5 ·
it shifts all four gears. when i give it gas it does stutter, especially when its at lower speeds. also i notice a stutter that's constant around third gear and shifting down to second or about 45-50 mph when going at a constant speed
 

·
Registered
Joined
·
617 Posts
Discussion Starter · #6 ·
Ok, its not the tranny because it just turned off on me while driving! Before it did I was at a stoplight and felt this weird feeling like the engine just shut off and on but real fast you could barely tell. Then when turning into a parking lot to check it out it turned off while driving. I put it in park and cranked it and it almost didn't start till I pressed the gas pedal! Any ideas, btw, there is one wire I haven't been able to replace that tells the other ones to fire, might be the coil, can't remember cuz my friend was doing it while I was out.
 

·
Premium Member
Joined
·
9,190 Posts
Ok, its not the tranny because it just turned off on me while driving! Before it did I was at a stoplight and felt this weird feeling like the engine just shut off and on but real fast you could barely tell. Then when turning into a parking lot to check it out it turned off while driving. I put it in park and cranked it and it almost didn't start till I pressed the gas pedal! Any ideas, btw, there is one wire I haven't been able to replace that tells the other ones to fire, might be the coil, can't remember cuz my friend was doing it while I was out.
never, ever EVERR start the car while pressing the gas....we have an electric starter, it will turn over or it wont.

whats the fuel pressure?

cleaned the maf latly?

check the egr

and iac.

report back
 

·
Registered
Joined
·
617 Posts
Discussion Starter · #9 ·
i just bought the PCV valve but need to replace it. where is it? I haven't cleaned the MAF. how do i check fuel pressure? I'm bout to check the fuses. also what is the IAC?
 

·
Registered
Joined
·
2,630 Posts
i just bought the PCV valve but need to replace it. where is it? I haven't cleaned the MAF. how do i check fuel pressure? I'm bout to check the fuses. also what is the IAC?
1st pic is the pcv valve, 2nd pic is the iac

IAC = idler air control, located on the bottom of your throttle body
 

Attachments

1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top