Chevy Impala SS Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,829 Posts
Discussion Starter #1
Hey, so I think my ED 7kv.2's died, which sucks cause although I bought them pre forum crash I didn't install them till last fall.

I've got a pair of 6.5" boxes mounted up on either side of the spare tire. I'd like to keep the box format because it leaves most of the baggage still usable.

Amp is an Alpine MRX-M55, apparently it might have been a bit much for the ED's.

So what's my best bet for a replacement 6.5"?

-Brian
 

·
Registered
Joined
·
1,114 Posts
How about a bit more information? How did you have them wired.......in series? Were you running 2-4-8 ohms. A 250 watt woofer doesn't hold up well with a 500 watt amp. If they were series wired then possibly only one of them is bad. What kind of money are you wanting to spend? I'm in the middle of installing a system in my Impala and looked into 6.5" subs for a SQ system. I chose a 10 instead. I made a bunch of notes about the 6.5" subs.
 

·
Registered
Joined
·
1,829 Posts
Discussion Starter #3
Wired in parallel 4ohm DVC's wired to 2 and then the 2 subs in parallel makes 1ohm total., should have worked out to 200w RMS per sub. Amp is 400w RMS at 1ohm. But if one let go then the other probably took the rest and died shortly there after.

I'll measure next weekend but I may be able to open up my boxes to fit 8" speakers.

-Brian
 

·
Registered
Joined
·
3,421 Posts
6.5 inch SUBwoofer? I am curious how well those performed pre-death. I managed to squeeze 2 - 10's in an infinite baffle type set up. That fit entirely under the rear package tray against the backseats. Although I eliminated the rear deck speakers in doing so. I ran a four channel amp and powered the fronts off 2 channels and each sub got their own channel. I was not feeding the subs their max RMS and the whole system still sounded GREAT when combined with sound deadener.

Wires were messy in this pic

 

·
Registered
Joined
·
1,829 Posts
Discussion Starter #5
I liked them. I wasn't gonna be rattling anything loose with them but they were a nice improvement over just the 6x9's.

For some reason I never took photos after I mounted them in the boxes.

-Brian
 

Attachments

·
Registered
Joined
·
1,829 Posts
Discussion Starter #6
So a measurement of Infinite Ohms across all combinations of terminals is bad right. I'm thinking of replacing them with a pair of Infinity 860w's. I've got an Infinity MX55 amp so it should be a pretty good pairing. They box is physically deep enough. (Barely) and I believe its in the 0.6cuft range on each box. Apparently these Hack boxes are rare. Atleast that's where I think my dad got them. I'm just bummed because he's got the same set up as me and it's been problem free for a few years.

-Brian
 

·
Registered
Joined
·
207 Posts
I liked them. I wasn't gonna be rattling anything loose with them but they were a nice improvement over just the 6x9's.

For some reason I never took photos after I mounted them in the boxes.

-Brian

I have two 10" shallow subs mounted in a nearly identical location (to preserve usable trunk space) and they sound impressive. I highly recommend you consider trying to shoehorn in 10s rather than replace 6.5s. I'll try to take pics when I have a chance.

My Subs:
Amazon.com : Earthquake Sound SWS-10X Shallow Woofer System 10-inch Car Subwoofer (Single) : Vehicle Subwoofers : Car Electronics
 

·
Registered
Joined
·
1,829 Posts
Discussion Starter #10
I'll get some more pictures this weekend. I'm not putting 6.5's back in. After some measuring I can get the Infinity 8's in with about 3/8ths of an inch clearance between the mounting depth and the back wall of the box. It'll be a little bit until I buy the replacements though. Gotta do a GTO clutch first.

-Brian
 
1 - 10 of 10 Posts
Top