Chevy Impala SS Forum banner

Status
Not open for further replies.
1 - 20 of 75 Posts

·
Registered
Joined
·
643 Posts
[Moderator note: This is for '94-95 Caprice and Impala SS, and also for '96 Caprice. '96 Impala SS has a unique cluster that has it's own problem and repair.]

I posted this a while ago and then the forum crashed, so I also had it on 9C1. net. Now that site is down. So I'll post it here again.











 

·
Registered
Joined
·
643 Posts
Discussion Starter #3 (Edited)
The empty cavity


Remove these 4 screws







clean these points with alcohol and a Q-tip. You can also pull on these points slightly with a hooked instrument so they'll contact the digital head better.

 

·
Registered
Joined
·
643 Posts
Discussion Starter #4 (Edited)






You can see how these contact points are dimpled. Touch them up lightly with a pointed soldering iron. You will need a very delicate touch here. Pretend your a brain surgeon.



And there it is, working again!

 

·
Registered
Joined
·
891 Posts
Nice writeup John.

I have a dead cluster downstairs that I took the easy route and replaced it. I may just have to try the soldering on it to see if I can make it work.
 

·
Registered
Joined
·
322 Posts
Excellent write up indeed. Followed the instructions and illustrations to the "T" ! Unfortunately however, my flickering digital display remains the same ?! Gonna upgrade to the Z28 Cluster soon, but wanted this setup to work for the time being. I did notice something though, your check engine light is illuminated (left side, bottom right ). Mine won't come on ? I switched bulbs with known working bulbs and still can't get that one to illuminate ?? Is this a major problem ?
 

·
Registered
Joined
·
43 Posts
Thanks for posting this. My digital dash keeps going blank in my 95 Caprice Classic, and I was wondering how to fix it! It seems to do it when the weather warms up, and it was a pain in the ass. Now with your help, I'm going to fix it this weekend. Thanks again.
 

·
Premium Member
Joined
·
1,906 Posts
I did notice something though, your check engine light is illuminated (left side, bottom right ). Mine won't come on ? I switched bulbs with known working bulbs and still can't get that one to illuminate ?? Is this a major problem ?
big problem when you take it for a smog check
 

·
Registered
Joined
·
48 Posts
trying this over the weekend.
wish me luck....

also my blinker lights are out on the display...would this be a fix for that?
 

·
Registered
Joined
·
48 Posts
ok...
cleaned and soldered the points, but i noticed when i pulled the unit out there were 2 huge black burn points underneath the epoxy. the only thing i can guess is the unit is totally out.

checked all my fuses but nothing works....
next step is to find another one from a parts car and go from there.
my alternator went out and thats when my digi dash died.

think that was the issue.
 

·
Registered
Joined
·
43 Posts
It worked great for me! I had mine out, fixed and back in the car in less than 2 hrs, and it works great! No more issues.
 

·
Premium Member
Joined
·
197 Posts
great info!!! But, if i use a gauge cluster from another car will the mileage change if i rebuild it? or will the computer turn it to the correct mileage?
 

·
Registered
Joined
·
88 Posts
how did you take the dash apart with the shifter in the way?
did you put the car in drive and hold the break? becuase i cant take it apart with the car in park???

and what did you do to the car before you started to take the dash apart?
did you take the battery out or anything like that?
 

·
Registered
Joined
·
643 Posts
Discussion Starter #17
You need to turn the key enough to put the shifter into low, without starting the car. They recommend you disconnect the battery to prevent accidental electrical damage. I did not myself.
 

·
Registered
Joined
·
88 Posts
okay thanks for the info ...i will do that.

and did you need to put solder on the circut board or just touch with a hot soldering iron?
 

·
Registered
Joined
·
88 Posts
okay i will make sure i do that
thanks you saved me a lot of money.

and are your sure my tranny or anything else wont get damaged by shifting into low without turning the car on?
 
1 - 20 of 75 Posts
Status
Not open for further replies.
Top