Chevy Impala SS Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,465 Posts
Discussion Starter #1
No power to my brand new fuel pump, no prime power, nothing at all. the 10a fuel pump fuse is good on the pass side engine bay fuse box? Does Fleetwoods have a test port like the bbodies? I never heard this car run, so I bet it had this issue before I bought it.
 

·
Registered
Joined
·
6,744 Posts
Run a new separate ignition hot wire to see,after verifying a good ground circuit.
 

·
Registered
Joined
·
149 Posts
Check trunk harness for bad wire. When my fuel pump went out the harness in the trunk for the ground wire got hot and melted the connector in the plug. I installed a wire around the plug and fuel pump has worked fine since.

Since the tail lights went through same ground my car would run until you hit the brakes... So when you shifted out of park....
 

·
Registered
Joined
·
7,983 Posts
No power to my brand new fuel pump, no prime power, nothing at all. the 10a fuel pump fuse is good on the pass side engine bay fuse box? Does Fleetwoods have a test port like the bbodies? I never heard this car run, so I bet it had this issue before I bought it.
Can't say for sure on the Caddy but I thought all the LT engines had a test or Prime override wire.

If you can't find it, like 1slow suggested just run 12v and ground directly to the pump. If I were in your situation and before dropping the tank, unplug the 3 wire connector back near the bumper. On a b-body there should be a gray, black and purple wire. The black is ground and gray is 12v.

Take some wire and go directly from the battery back to this 3 wire connector or use a 12v power source and connect the wires directly to the unplugged harness for a few seconds and see if the pump runs and pressurized the system. If if does....then you got a wiring problem in the circuit before the harness connector you need to trace out. If it does not, then odds are good you have an intank issue. (Most likely wiring) and time to drop the tank.
 

·
Registered
Joined
·
1,465 Posts
Discussion Starter #5
I plan on bypassing the factory wires tomorrow, The pump and sender are both new and installed by me. The Fleetwoods have four wires back there going into the sender. I bet the grey on is still the power. Ill find out tomorrow.
Also I think the Fleetwoods have a separate Fuel pump relay bolted on the firewall somewhere.
 

·
Registered
Joined
·
7,983 Posts
Wow, 4 wires. I saw a picture of a sending unit and do see 4 wires. I wonder what that 4th wire does? Cause all you normally have on the b-Body is your 12V, Ground and Sending unit Wires. but like you said, I would assume gray is still Hot and black is ground.

At any rate, I did a quick Google search and there does appear to be Schematics out there on theweb that could help you. I did find a post where someone mentioned the relay is mounted on the FW like you said. Also found this link to the Caddy forum and there may be more info there for you if you hunt for it. Also in 1 of the Schematics I was looking at, they did show a "Prime Wire" in the Schematic.

Fuel pump not priming
 

·
Registered
Joined
·
7,866 Posts
Fleetwoods have a different sender from B-bodies and I recall use 2 wires. My '96 has the normal test lead, but it's coming out of a loom going to that relay on the firewall instead of over by the plug to the A/C.
 

·
Registered
Joined
·
1,465 Posts
Discussion Starter #8
Thanks, Got it fix, Pump worked with the jumper red wire power.
So I found a bad ground wire at the usually loom at the coil bolt connection. Fired her up today for the first time, sounds great, not as idle lumpy as most my builds, but hey it is a Cadillac !!! LOL and it only has a GM 845 camshaft with all the other usually goodies and upgrades. Should be a torque monster with the new 2800 stall and Caprice rear rear disc rear end with Eaton posi/373 gears.
 

·
Registered
Joined
·
7,866 Posts
Good deal. I know you have a couple of FWs in the works. Is this the one you're eventually selling?
 

·
Registered
Joined
·
7,983 Posts
Thanks, Got it fix, Pump worked with the jumper red wire power.
So I found a bad ground wire at the usually loom at the coil bolt connection. Fired her up today for the first time, sounds great, not as idle lumpy as most my builds, but hey it is a Cadillac !!! LOL and it only has a GM 845 camshaft with all the other usually goodies and upgrades. Should be a torque monster with the new 2800 stall and Caprice rear rear disc rear end with Eaton posi/373 gears.
That's right, riding in a Cadillac should feel like you're floating on a cloud. We had a 79 Fleetwood Brougham and the interior/ride was so comfy I described it as sitting in the hand of God. That thing was a 425 c.i. Tank but it just floated down the road.

Does sound like some nice upgrades that should make the ride even more fun. That certainly is a good selection of performance upgrades and partial to the 3.73's myself. IMHO - All these heavy cars should have had a steeper gear....but then again the clientele that these cars were geared to were more interested in the Floaty Feel. It was us crazy arse kids that wanted more in Performance and Handling. Blasphemy?, maybe, but I don't care. :wink2:
 

·
Registered
Joined
·
1,465 Posts
Discussion Starter #11
Well, this one should be nice with the upgrades, but still a Caddy look. It has Hotchkis Lower control arms, BMR upper both stock length, Hotchkis front and rear sway bars, the Moog 7268 front springs, and wagon rear springs with Blistein shocks,
Here is a pic of the engine a while ago with the flowtechs and custom H pipe. Ill try to take a few new pics before the first drive.
I need to figure out how to delete the traction control throttle cable thing, all the other parts for the traction control are long gone. I wonder if a regular Bbody throttle cable would work since the fleetwood is a bit longer up front.
This Fleetwood thing is all new to me, but it has been a blast to build.
Just picked up a 94 DGGM Roadmaster for my next project.

Bob, I'm sure it will be up for sale soon, I still need to install the Blazer floor shifter. I found a black floor shifter and console at the Jyards a few months ago, and also bought a 57k Passenger seat that is a perfect match to my black interior on Ebay. so I will not have to hack up the original driver seat to make them buckets.
 

Attachments

1 - 11 of 11 Posts
Top