Chevy Impala SS Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
231 Posts
Discussion Starter · #1 ·
Motor ran great before accident. msd wires, all accessories, flywheel, TB, maf, intake. no exhaust manifiolds. 400

9c1 posi rear, rotor to rotor 300

Located in Baldwin NY (long island)
 

· Registered
Joined
·
576 Posts
do you have the pieces that bolt onto the lower rear control arms that the sway bar bolts to?
 

· Registered
Joined
·
576 Posts
I think so - I'm not sure what it's called, but I think there is a piece that goes into the middle of the control arm groove that has nuts for the sway bar to bolt to - I'm just going by the description that someone else gave me - but I have the factory stamped control arms and need whatever is required to attach the sway bar - someone told me that there was a piece that fits into the control arm that the sway bar bolts to.
 

· Registered
Joined
·
1,532 Posts
I think so - I'm not sure what it's called, but I think there is a piece that goes into the middle of the control arm groove that has nuts for the sway bar to bolt to - I'm just going by the description that someone else gave me - but I have the factory stamped control arms and need whatever is required to attach the sway bar - someone told me that there was a piece that fits into the control arm that the sway bar bolts to.
I think I've got a set if you are still looking for the brackets. LMK. Thanks.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top