Chevy Impala SS Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter #1
have a 95 LT1 with these digital dash.

The digital part and the gauge illumination ONLY come on when the park light's and then dash light dimmer is turned up and turns the dome light on.

Anyone seen this? have a 95 LT1 with the digital dash.

The digital part and the gauge illumination ONLY come on when the park light's and then dash light dimmer is turned up and turns the dome light on.

Anyone seen this?
 

·
Registered
Joined
·
1,702 Posts
have a 95 LT1 with the digital dash.

The digital part and the gauge illumination ONLY come on when the park light's and then dash light dimmer is turned up and turns the dome light on.

Anyone seen this?
I know the thumbwheel spins up and down.

Does anything happen when you try (as weird as this sounds) to wiggle the thumbwheel from side to side?
 

·
Registered
Joined
·
1,092 Posts
When the solder cracks on these circuit boards all sorts of things happen. Have a look at the STICKY:
https://www.impalassforum.com/vBulletin/26-electrical/272461-1995-9c1-intermittent-dash-display-fix.html
ShudahadaV's documentation of cracked solder on the board fixes most issues.


Your problem may just be bad car connector to the cluster. Have you unplugged the cluster? If that "fixes" it spray the plugs with contact cleaner (not WD-40). Just handling the cluster may flex the circuit boards and temporarily make contact. If it fails again soldering the board pins may be the fix.
 
1 - 3 of 3 Posts
Top