Chevy Impala SS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Ok guys and gals, Right at about 1 year ago to the day I had my compressor replaced. I've noticed over the last several weeks that the air is no longer blowing cold. I checked the pressure and it was low, so I re-charged. Next day pressure is low again. So I took it back to the garage that did the compressor install to have it checked out again. He calls and says that the condenser is bad. The problem that I'm having in no cold air and a phsst sound that varies between 30 seconds to a minute. The mechanic said something about the condenser overheating or getting too hot and that is what is causing my problem. any thoughts on whether this is accurate? Anyone else replace a condenser out there?
 

·
Registered
Joined
·
3,612 Posts
The mechanic gave you a BS answer. Pop the hood, look at the compressor. You're probably hearing the compressor kick on and off since the system is low on refrigerant.

Condensers go bad all the time. Usually, its the result of some sort of impact; a rock, an animal, etc. Ask how they determined it though. They should have put UV dye in the system to find the leak. It will glow under a blacklight.
 

·
Registered
Joined
·
1,702 Posts
well first off there is obviously a leak somewhere. I would have questioned them more about it since they put it in.it's a sealed system as with every AC in the world. if it's low it leaks simple as that.

Low refrigerant can cause damage
 
1 - 4 of 4 Posts
Top