Chevy Impala SS Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
586 Posts
Discussion Starter · #1 ·
My a/c compressors keeps turning on and off when i put freon into accumalator because my a/c stopped blowing cold so i put fron in and all of a sudden the compressors turns on and shuts off in 1 sec intervals........next i noticed loud hissin sound and i look down ( see video for details) and see oil drippin on pipe or somethin.......any ideas on a quick fix till i can get an estimate on fixin leak? unless anyone has had this prob and can tell me if this kind of leak is expensive because it leaked all freon out in like 5 mins....


 

·
Premium Member
Joined
·
2,547 Posts
The hose assembly that comes off the back of the compressor has most likely has a hole in the hose which is closest to the CTRL arm.

This is a common problem with our cars, that comes from the hose rubbing on the CTRL arm as the suspension goes into jounce and rebound.

You'll have to buy a new hose assembly, as well as sealing washers.

The hose assembly can be bought thru RockAuto (Check MISC section sticky for 5% discount code):

1. FOUR SEASONS Part # 55903, $60.99
2. AC-Delco Part # 1532464, $87.79

The last thing is the sealing washers at the back of the compressor. I believe you'll need a 17MM socket to get that flange nut off. These are ~$10 at the stealership. P/N: 2724577.

See this thread that is stickied that I posted a lot of helpful information to regarding A/C service:
http://www.impalassforum.com/vBulletin/showthread.php?t=244168

A preventative measure that's common is to wrap a piece of heater hose around the A/C hose to prevent this from happening again. You can see it here:



As an FYI: You only need to wrap the hose closest to the CTRL arm (Red hose). I did both, since I had some extra hose lying around when I was doing a bunch of work this summer.
 

·
Registered
Joined
·
3,612 Posts
Are you absolutely sure you're hearing a leak, and not just the pressure equalizing in the system?

If your compressor cycles on and off, you're low on refrigerant. Keep adding, if it's not all blowing out through a leak.
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #5 ·
The hose assembly that comes off the back of the compressor has most likely has a hole in the hose which is closest to the CTRL arm.

This is a common problem with our cars, that comes from the hose rubbing on the CTRL arm as the suspension goes into jounce and rebound.

You'll have to buy a new hose assembly, as well as sealing washers.

The hose assembly can be bought thru RockAuto (Check MISC section sticky for 5% discount code):

1. FOUR SEASONS Part # 55903, $60.99
2. AC-Delco Part # 1532464, $87.79

The last thing is the sealing washers at the back of the compressor. I believe you'll need a 17MM socket to get that flange nut off. These are ~$10 at the stealership. P/N: 2724577.

See this thread that is stickied that I posted a lot of helpful information to regarding A/C service:
http://www.impalassforum.com/vBulletin/showthread.php?t=244168

A preventative measure that's common is to wrap a piece of heater hose around the A/C hose to prevent this from happening again. You can see it here:



As an FYI: You only need to wrap the hose closest to the CTRL arm (Red hose). I did both, since I had some extra hose lying around when I was doing a bunch of work this summer.


The leak isnt coming from a hose its from the rusted part u have in pic its leaking under it to left of red hose looks like a shock or something
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #6 ·
What cletus said, if you had a leak and you were filling it with freon, it wouldn't even try to cycle anymore especially if you are seeing something drip, that would be a huge leak, probably just air in the system.


I do hear a loud hiss like refrigerent leaving from that spot, also it seems looks like oil coming from that spot as well when i say loud u can hear it like you blew a head gasket
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #7 ·
so if my compressor is tryning to kick on but turns off while i put freon in low side that doesnt mean its a leak? maybe it could be the pressure, but then what is the oily substance i see dripping out when the loud hissing is heard form leak spot?
 

·
Registered
Joined
·
3,612 Posts
I do hear a loud hiss like refrigerent leaving from that spot, also it seems looks like oil coming from that spot as well when i say loud u can hear it like you blew a head gasket
so if my compressor is tryning to kick on but turns off while i put freon in low side that doesnt mean its a leak? maybe it could be the pressure, but then what is the oily substance i see dripping out when the loud hissing is heard form leak spot?
Man, you are going to have to do a better job describing exactly where or what you're seeing, or we won't be able to help you. You should be able to track the source of the oil leak. As for the loud hissing, I can't tell you. I can tell you all AC systems make noises when the system is shut off and the pressure equalizes in the system.
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #9 ·
ok look at picture above.....what is that thing called to the left of red tubing? its rusted a little and it kind of looks like a manifold somewhat lol sorry guys its just i dont kno too much about car parts and stuff so bear with me as i learn little by little, ok the leak is dripping under that rusted manifold looking thing, as for the hiss i cud not see where but judging from sound and oil drippage from that manifold looking thing its there
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #11 ·
i saw some kind of fluid leak from that arm spot then........ and hissin must be coming from hoses ill verify n do another vid while in action
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #12 ·
hey guys found out it was my ac/compressor hose had a huge hole which squirted out on the spot i thought was leaking, i went to once again midas to see if they will try and rip me off.....what do you kno these guys tried to charge me a total of $662 just to get a new hose and charge a/c lmfao. so i went to auto parts store and bought hose for 70 bucks and had it installed for only 50 bucks so a total of 120 sounds alot better than what midas was tryning to charge, and another thing it also fixed my cooling fans prob as well because once my a/c works my fans come on now, so the problem was my airbags i have in car i lowered it too low and it kept rubbing on hose so i had it moved a lil to avoid it now
 
1 - 12 of 12 Posts
Top