Chevy Impala SS Forum banner
1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
So I couldn't sleep this morning,so I get out and start working on the Caprice.I had a Tali light out so I started messing with it.Of course I go to the local Autozone and get a couple of new bulbs.An hour later,I finally took the bulbs out of my 91 Caprice to get my turn signals to work!!!!I don't why this does this????ANY ANSWERS????Had to mess around with all the bulbs I had before I finally found a couple that would work together.So as I was finishing up,up pulls the Fed Ex dude!!!WOO-HOO!!!I ordered a K&N CAI 2 days ago and it came in this morning less than 36 hours after i ordered it!!!So i get right to it and get the CAI installed.Wasn't too awfully hard even for a dummy like me.Still have not drove it yet.I have to go get some more bulbs to get the 91 Caprices tail lights back together in a little bit.I guess I'll see what my $214.00 bought me.
 
G

·
Discussion Starter · #4 ·
Originally posted by caddyguy109:
Very cool. Make sure to post some comments after you've driven it thoroughly after with the K&N ;)
I went and drove it late yesterday.WhenI ordered it I was very reluctant to.I had a K&N Filter in my old 86 Chevy 4x4 truck and replaced it with a high flow regular filter and noticed a big difference with the regular filter.So i was very skeptical.
So I went and drove it yesterday with the wife.She wanted to see also what "OUR" money had bought "us".I was pleasantly suprised by the CAI.Has more throttle response.Feels like firmer shifts and acceleration is better.The cruising speed acceleration is where I was really pleased.Cruising down the road at 60-65 MPH and put it to the floor and it runs like a ass raped ape!!!

All in all,I am very happy so far with the Intake and would recommend it to other LT1 owners.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top