Chevy Impala SS Forum banner

1 - 4 of 4 Posts
C

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I was in a accident about a month ago and my white corner bulbs havent worked (when i use the turn signals) since.Ive replaced them and all that and the still dont want to work.The 20 amp fuse is fine and if they dont work right now I guess I can deal with that till it warms up so I can stand to be out side with a volt meter,but now my right hand turn signal dont work,It quit once before when I didnt have new bulbs in,then I replaced them and it worked again,now recently it dont work again.Just the right hand signal.Im not sre what could be the problem,any ideas on things to check?Thanks in advance.
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #3
i had this happen to my left blinker after i hit a deer. it pulled the wire just enuff that it barely made contact. follow your wires and push them in to the grommet (rubber base of light) a lil farther. sometimes u hafta tape them or bend them to git the connection right.
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #4
I figured it out I watched my girl take off in my car to cruz to pick up my bro from a friends (his altinator died/R.I.P. 92 ford ranger altinator,lol) and when she pulled off I saw that I had a light buld out in the rear on the right so i went to the store bought a new one and wa la,she works!(the turn signal on the right hand side i mean).Now its just those front non functional bulbs in the turn signals I gotta work on!Ill try to see if its just a connection though thanks.
 
1 - 4 of 4 Posts
Top