Chevy Impala SS Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
559 Posts
Discussion Starter · #1 ·
What's up guys i have a problem the ac keeps running low on coolant for some reason i had a local shop do the standard preassure leak test but the machine said that it was fine. I think i read on here somewhere that it might be that i need to replace my heater core or something of that nature. I also get the dreaded foggy windshild from time to time. No visible signs so far. By the way i have a 95 impala ss. Thanks
 

· Registered
Joined
·
174 Posts
Cooling system of Air conditioning system?
You losing Coolant or Freon?
 

· Signature Section Moderator & CrossFire Club Ambas
Joined
·
6,314 Posts
Sounds to me like you got a few problems.

If its the heater core, its your coolant, NOT your freon. If your heater core is clogged, you generally won't get heat. It might also be something like the blower motor or the unit that switches between hot and cold (don't remember the name).


NOW, if its freon, you can just put some R-134 (I think thats right) into the A/C condenser thing and that will solve the freon portion of your problem....


But A/C and coolant.... different beasts. There is a way to check your heater core.... the hoses should be hot that go in and out of the firewall. If one of them is cold and the other hot, your heater core is clogged.... Can anyone confirm me on this?
 

· Registered
Joined
·
11,630 Posts
You must clarify your problem. You are mixing terms. We can not help you unless you define the problem correctly.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top