Chevy Impala SS Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
664 Posts
Discussion Starter #1
What controls the analog gauge and the over heating light ?
My analog gauge "runs" way hotter than the PCM is reporting. At 225, the analog gauge is in the red, and sometimes the over heating light will come on.

Car is all stock, 96 SS
 

·
Registered
Joined
·
6,842 Posts
Gauge sender is located on the passenger side cylinder head. It is far from a precision instrument though. I use/recommend aftermarket gauges for increased accuracy....
 

·
Registered
Joined
·
428 Posts
I noticed that with out the little heat shield the temp gauge will read hotter. its also not very accurate. I recommend autmeter.
 

·
Registered
Joined
·
1,090 Posts
Other issues?

Check Gauge light is controlled by a chip on the cluster from the gauge sensor.

I changed to a Olds grill and my temp gauge went up but the PCM scan showed about the same temp as before.

These cars were used by police in Arizona, Texas, New Mexico, and California. They were shipped to Arab counties. My point is that many things push the temp up on these old cars. Old slower fans, problems inside the radiator, or blocked rad or AC fins.

You could change the sensor or test it. I spent my time on the cooling and AC system. The temperature is different in different parts of the motor. But usually the gauge is trying to tell you there is a problem before high temperature does damage.

Cool thermostat and reprogramming the fans will probably give you more satisfaction than hacking up the car to add a aftermarket gauge.
 

·
Registered
Joined
·
6,842 Posts
Problem is regardless what you do,or don't do...Without an accurate gauge you still won't know what the coolant temperature is. One can easily be installed without "hacking up" anything....
 

·
Registered
Joined
·
7,988 Posts
While some may use/recommend an aftermarket gauge/sensor for accuracy, there are still many that may just want to keep it stock (looking). Most don't want their car to resemble a fighter jet cockpit or to modify stock parts to mount and route the components of an "accurate" temp gauge....assuming a mechanical gauge here. An electrical gauge would still require something modified to mount the gauge and run the wiring. While you may find an obscure place to put a gauge that could be easily replaced, it still leaves some piece of the interior that would need to be cut, hacked, drilled or modified from stock...i.e. A-Pillar or dash face. The blur's car is described as "stock" in his first post and AM gauge/sensor may not help him much.

Blur - assuming you are trying to keep your car stock and living with a gauge that may be off somewhat, what things have you done to clean up (flush) the cooling system? I would recommend a full flush and clean of all components to the cooling system...,rad, reservoir tank, heater core, hoses and block. Once that is done, be sure to bleed the system and then see how your factory gauge responds.

If you suspect a problem with the gauge and/or sensor I would recommend that you get an inexpensive infrared thermometer and see what temps you are actually reading at places like the Tstat housing, water pump, block, etc. once you determine for sure the issue, then you can proceed with trying to correct the issue. Maybe the temp is actually fine and you just need to adjust the gauge (move the needle) or take into account it just "reads" high and factor that in. Just like having a speedo that is off by 5 or 10 MPH.
 
1 - 8 of 8 Posts
Top