Chevy Impala SS Forum banner

1 - 4 of 4 Posts
F

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Just finished the body bushing upgrade about 5 hours ago.
Couldn't wait to get the SS on the road. I just didn't believe it would make as big a difference as it did. :D Even my wife noticed the difference as I was blastin' up & down the back roads on our way to dinner. The car was so much tighter and the rattle factor of a nine year old car was reduced by at least 50%!! :D :D Read all the different write ups about this mod and once I got started it took about 90 minutes. That included the setup and tear down with the floor jack and jack stands. If you have not done this mod you really need to!! You don't know what you are missing. Got my bushings from GMPartsDirect.com. Still waiting for the ZQ8 bumpstops to arrive. :(
 
F

·
Guest
Joined
·
0 Posts
Discussion Starter #3
I don't know about the gap that everyone is talking about. When I did mine, from what I could see everything looked good. Everyone talks about how hard the bolts are to take out, but I was able to take them out with just a standard ratchet. I will say that the last two at the rear bumper were a little harder to get out, but I didn't need a cheater bar. I had some rust issues with the bolts in #7 spot, the shanks were undersized after cleanup. I have ordered new bolts to replace those. Also, at the #7 spot the body raised up from the frame and I couldn't get the bolts back in. I had to take the car off the jack stands and use the floor jack to put upward pressure on the frame rail so I could start the bolts back in. That was the only problem that I had and it was very minor.
 
E

·
Guest
Joined
·
0 Posts
Discussion Starter #4
I just finished installing upper and lower body mounts,it went farley well,7 michigan and pennsillvana winters made the bolts alittle stubborn,squirted oil on em best i could for 2-3 days,1/2 breaker bar,easy like,back and forth, the first bolt I atempted(middle of drivers door) I spun the hidden "nut" in its trap.that sucked big time.Ithought for awhile about sending mounts back,another coffee or 2,I pulled carpet back inside drivers door,transfered location of bolt to top side(combination square)drilled a1/2 hole,it was alittle off location,but by now I could plainly see what was going on ,"nut" is thick(1/4,5/16)pc. of sheet meatal,trapped in cage,it had broken loose and was spinning freely,now at least i could pour oil on it! I moved off center line of bolt about 3/8s of a inch,dilled a1/4 hole all the way thru to upper mount,into upper mount,drove a 2"long 1/4 roll pin(split pin)in to trap nut,it worked!!!!!!!!!! beleive it or not,the rest of the bolts broke loose with just alittle effort,Iguess I picked the wrong bolt to start with!! Any way all went well after that.I think I will retorge after car is on floor,as Ithink frame was flexed on jack stands,maybe not but it aint gonna hurt,Inever seized the snot of them bolts too(after wire wheel)NOT THE RUBBER MOUNTS,
I then started to drink beer,kept on drinkin beer,so its still up in air,today carpet and trim go back down and shes goin for aride,
OH YEAH,GOOD LUCK with yours newbies, alls well that ends well?
 
1 - 4 of 4 Posts
Top