Chevy Impala SS Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
531 Posts
Discussion Starter #1
OK, What can I do to help this battleship hook?

It did great with the stock cid but now I'm 383 and I have brand new Nitto 555's on it and get them damn hot. It blows the tires off. YES I know I'm making a lot more hp and tq but I just can't get that squatting feel like it wants to hook.

The car has 1.5" lower springs and aftermarket upper and lower arms w/ poly bushings. Pinion angle at 1.5*. My drag radials are shot and I know a new set would help.

It just feels like it just wants to ride a burnout for miles...and it does. Great for cruise nights to piss off the cops. But I need to hook better than what I am.

I know there's guys on here making a lot more hp than me that hook well.
 

·
Registered
Joined
·
2,925 Posts
My guess is the if you look at the tire is will show you the compound rating, ie. its hardness.
compare it too the drag radials and you may see why it is so easy to break loose a street tire.

I think it's a combo of things, trying to hook on a street tire with a motor with decent HP.

How fast you squeeze the throttle?
How much you load up the TQ converter?
Track prep ?
Susp mods ?

we can go on and on.....

Maybe if you tell us where you are trying to hook, we can give you a guess?
-ALF out....
 

·
Registered
Joined
·
531 Posts
Discussion Starter #3
Well, on a last minute decision after work last night, we ran down to the local track for T&T. Other than quite a few disastrous mistakes on my part, I got 2 good runs in. Here's the best run:

RT: .0350
60': 1.8488
330': 5.3619
594': 7.7680
1/8: 8.306
MPH: 83.49

No matter how bad I did off the line, 11 runs were at 83mph. The 555's were inconsistent. Only 3 runs they hooked hard and all the others the blew off. They did had to get hot. I did the same burnout each time. But the 60' is the best it has on this new build. My wife would cut 1.7 and 1.8 with old setup (stock 350 w/ hotcam, 3200 stall)

Better tires in order I guess. Oh and new cam for more topend power. Anyone interested in a stump puller cam?
 

·
Premium Member
Joined
·
3,774 Posts
Mid 1.8X 60' times are not bad on street tires, so don't expect much better until you get some drag tires under it. Don't heat up street tires; you're making matters worse. Unlike racing compound, they just get greasy when you heat them.
Even your old drag radials would do better than new 555's.
Have you corrected your lower control arm angle with LCA relocation brackets since you lowered the car? If not, there's an opportunity.
 

·
Registered
Joined
·
5,243 Posts
Just get some slicks and you'll be good.
8.30 in the 1/8th roughly translates to 12.86 in the quarter.
Whats the specs on your "stump puller" cam?

Nab
 

·
Registered
Joined
·
57 Posts
Ya blue wail is right, just get some slicks with
15 inch wheels. I don't even bother going to the
Track without slicks. Even my little 15x8 Hoosiers
Have netted 1.58 60fts on spray. It's frustrating
Going to the track without traction. 83 mph
Sounds about right for your time though . Although
It seems low for a 383 unless your car is heavy.
If it doesn't hook on slicks, you may want to take a look
At your suspension . On the street, forget about it, it's a lost
Case .I don't hook up on the street even with slicks .
 

·
Registered
Joined
·
531 Posts
Discussion Starter #7
Nab, 228/234, 576/576 w/ 1.6, 112. Tq curve was flat from 2800 to 5000 from just below 400 to about 450tq. Hp started low and just barely broke 400. The tq was diving down towards 5200 as the hp was coming up. Cam motion designed this grind.

I do not have any relocation brackets on this car. Might look into that. As for the tires, I tried a cold tire and blowing them off is an understatement. The car started North, then West then East.... Didn't want to end up going South so I got out of it quick. I tried a few heat levels in the burnouts. These 555's like to be real hot. Semi hot they were pretty greasy. Basically they are just like my MT DRs. Gotta really roll the smoke and they hook.

The best run was my first. (sarcasm) I haven't been on the line since April or so. I saw the first yellow light flash on and I jumped. Man, did I look like an idiot. LOL So I let the other guy launch then I gave er hell.
 

·
Registered
Joined
·
8,488 Posts
get MT ET Street (tube) 26x15 or full slick

start around 16 PSI. Do a short burnout to heat/clean them up

I would recommend a line lock vs power brake to heat the tires up

try launching off idle. If tires hold you can try a slight power brake launch

I found the Dick Miller triangulation braces help. Could also try a air bag in PS rear spring

T&T days typically have zero to little track prep so it is what it is.
 

·
Premium Member
Joined
·
20,295 Posts
Nab, 228/234, 576/576 w/ 1.6, 112. Tq curve was flat from 2800 to 5000 from just below 400 to about 450tq. Hp started low and just barely broke 400. The tq was diving down towards 5200 as the hp was coming up. Cam motion designed this grind........
What's your compression ratio?

Who did your heads?

And like Pat and Nab stated, you're not gonna improve your launch without some drag radials or slicks.

KW
 

·
Registered
Joined
·
531 Posts
Discussion Starter #10
BALLSS, Track prep was great. They had a bunch of doorslammers there getting ready for their finals this weekend. I had a few of those tires for my Camaro. great tires. I'm just trying to get the best all around set up.
I do have a Line lock installed and ABS is deleted, just not wired up yet. Just haven't gotten around to doing it. I'm still trying to decide where I want the button. I already have all the nitrous buttons in the dash bezel. (not hooked up, need new solenoids)

KW, The CR is 11.2 and the heads were just unshrouded and port matched years ago when I had my hotcam. But for this build I had bigger valves installed. I already had a full set of S/S valves on the shelf so I figured I needed to use them. This cam has alot of cam surge. In traffic is really bad and at 55-65mph you feel it too.

Hopefully this winter I can blast a bunch of money into this extra LS1 I have and drop it in.
 

·
Registered
Joined
·
1,841 Posts
I had similar cam surge issues, I switched from LS1 dwell tables to truck dwell tables and it mad a huge improvement in idle/cruise.

UMI's relocation brackets felt like a huge improvement in the hook. 3k launches on 555R's still seem to hook just fine. Not much of a burnout though, just enough to knock the gravel off. Although I'm not sure what's really going on cause I'm only cutting 2.2's on my way to 13.8 @ 105. Maybe it's time to lower the pressure and try for 4k.

-Brian
 

·
Registered
Joined
·
531 Posts
Discussion Starter #12
Good to know on the dwell tables.
i might try that this weekend.
thanks.
 

·
Registered
Joined
·
8,488 Posts
BALLSS, Track prep was great. They had a bunch of doorslammers there getting ready for their finals this weekend. I had a few of those tires for my Camaro. great tires. I'm just trying to get the best all around set up.
I do have a Line lock installed and ABS is deleted, just not wired up yet. Just haven't gotten around to doing it. I'm still trying to decide where I want the button..
well if you are spinning with good track prep....attention to a "tire" and other rear suspension mods (DM brace, air bags, etc) along with launch technique will be needed.

I go to Famoso near Bakersfield, CA yearly when they have their NHRA T&T (before season starts) where track prep is real. Non NHRA members pay $100 but members (me) pay $50. They leave a lane for us "street cars" as everything else are haulers running mostly license passes & T&T shake down runs. I can get 10 runs in by noon as there are very few "street" cars.

With real track prep.....you can seriously "bog" on launch if you don't leave with enough RPM

FWIW I mounted my line lock button in the coin slot on left side of dash.
 

Attachments

·
Registered
Joined
·
531 Posts
Discussion Starter #14 (Edited)
Is that a momentary switch? If so, where did you get it? I've been looking for a lighted momentary that will hold some amperage. Most are only 5 amp and not lighted.
 
1 - 14 of 14 Posts
Top