Chevy Impala SS Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 94 buick roadmaster that has developed a bad miss and is backfiring. Ran the trouble codes through climate control and no codes come up. Bad PCM?
 

·
Registered
Joined
·
65 Posts
prob a dist, cap, wires, fuel press , coil , icm , not pcm very rare on that one how many miles are on these?????also go to the eng probs on here and look at the first sets of sticky posts as those will help you on your quest ... grasshopper.....
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
thanks. Ive done the plugs, wires, TPS, IAC, both o2 sensors, fuel pump, fuel filter. the car has 199,000 miles. Idles great, but under a load pops and bangs. Doesnt matter warm or cold, but gets worse the hotter it gets. Have a cheap scanner that says its going into closed loop too. Oh yeah, I've done the coil and pick up too.
 

·
Registered
Joined
·
65 Posts
hi you did replace the dist cap with a good brand ???even a new one can crack inside making it misfire ....did you have the icm checked most auto stores have a ignition tester.... is there oil or water leak coated on the dist was it running good then all this happen or were you working on it and now have issues ??
///
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Might be the cap. Didnt replace that yet. Wanted some advise before I threw any more money in it. Thanks for the help
 

·
Registered
Joined
·
3,505 Posts
Is Opti vent harness working? Are plug wires run to wrong plugs(yes, that happens)? Cap and rotor should be replaced at about that mileage. Delco, Delphi, MSD are the sets to use.
 
1 - 6 of 6 Posts
Top