Chevy Impala SS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 ·
my car cannot pass emissons hear in az im failing hydocarbons and carnon monoxide how can i fix this problem
 

·
Registered
Joined
·
581 Posts
I would check the catalytic converters. I had a simliar issue on the first 9C1 I bought and it turned out that one of the cat converters was gutted. Of course If they are bad other things may be bad as well, O2 sensors, plugs, wires, opti, etc. Even the coolant temp sender in the waterpump (94-96 B-Bodies) could be bad causing the car to run rich. Tell us more about the vehicle, year, model, and engine. Also has any work been recently done to the vehicle? - Peter
 

·
Registered
Joined
·
981 Posts
Tell us more about the condition of your engine, last maintenance items, age of replacement parts, etc. Could be O2 sensors. Could be cats. Could be a little gremlin like I have living in the left side of my engine.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #4 ·
it has new o2 censors both cats have already been changed the car has many bolt ons and 411 gears so i think it revs way too high when their on it i bearly failed im wondering if i pour denatured alcholhol if that can fix my problem
 

·
Registered
Joined
·
3,612 Posts
What brand of O2 sensors? How about plugs, wires, PCV valve, etc. These engines run very clean when in proper tune, so the 4.11 gears alone should not make you fail. They do, however, make your fuel economy fail.

What are your 'other bolt ons'? Has the PCM been reprogrammed?
 
1 - 5 of 5 Posts
Top