Chevy Impala SS Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter · #1 ·
Just changed my torue convertor to a 23-2500 stall also with lt4 kit. Must have drove 150 miles after the kit, and the check engine light came on. 96 imp with 70,760 miles, stock tranny, stock gears 3.08. CAr is driving fine tranny is not slipping. WHat could this be????
 

·
Registered
Joined
·
8,572 Posts
http://www.impalassforum.com/vBulletin/showthread.php?t=243389

There's several more if you Search P1870

Mine has been getting that code too, but only after 5 years running fine after full rebuild and 3000Edge with reprogramming.

Over the past several months the light has gone from resetting itself once or twice to solid now.

I would have thought I had all the bases covered considering I used a full TransGo and reprogramming for the converter. I haven't been able to confirm from the gurus, but from all I can gather the valve must still be an issue despite everything else done and still has to be staked.

EDIT: I just noticed that even your replacement stall is not so high. The code is supposedly able to be programmed out for guys using hi-stall convertors. You may want to contact one of the programmers on the forum and see what they say before you do anything to the tranny.
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #4 ·
Time for a tune. LT4 kit has different airflow than stock, obviously, and the trorque converter settings need to be updated to reflect the converter, otherwise it will continue to set the code.

Chris
Should I dyno tune it and also take it 2 a tranny shop?
 

·
Registered
Joined
·
3,913 Posts
Have a mailorder done first to dcorrect for the stall issue, the drive it for a while. see if the code comes back. I would do the mod method suggested in the transmission sticky if you decide not to do the tune fix. DO NOT do both it WILL KILL your trans.

Chris
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #6 ·
Have a mailorder done first to dcorrect for the stall issue, the drive it for a while. see if the code comes back. I would do the mod method suggested in the transmission sticky if you decide not to do the tune fix. DO NOT do both it WILL KILL your trans.

Chris
Thks I'll try it out.
 

·
Registered
Joined
·
8,572 Posts
..... DO NOT do both it WILL KILL your trans.......

Chris
Chris, without even knowing it that's been my fear. So, what's the best tact since I'm now getting the code after 5 years (maybe 15k miles) and the hi-stall is purportedly already tuned in by an ace forum tuner?
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #8 ·
A guy quoted me $400 to do the solenoid which includes all 5 piece. With new tranny filter nd fluid. These is a side job he would do it at his house so its cash. The guy doing it for me owned a tranmission shop for 25 years and is currently retired. Does this sound right?
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #9 ·
Time for a tune. LT4 kit has different airflow than stock, obviously, and the trorque converter settings need to be updated to reflect the converter, otherwise it will continue to set the code.

Chris
NOw im thinking is it even worth it spending the money, beacuse in the long run isnt my tranny go out anyway beacuse of the lt4 kit? I dont know if it will?

In the past how has the 4l60 stock tranny held up with others with lt4 heads nd cam?
 

·
Registered
Joined
·
3,612 Posts
Why replace all the solenoids? The fix is to stake the PWM valve body. Bad solenoids in the trans will throw codes.
 
1 - 10 of 10 Posts
Top