Chevy Impala SS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
580 Posts
Discussion Starter #1
My climate contrail suddenly stopped working on my '94 RMW. Now it blows only very hot heat through the vents. Display is completely off. Any ideas what happened?
 

·
Registered
Joined
·
8,197 Posts
I'm chasing an A/C gremlin too in my FWB, but quite different. "Blows hot air only" could simply be lost Freon (for that just check if your compressor runs or not). The "Display is completely off..." part is confusing. .Let me and everyone understand that you have a completely dead (no lights nothing) A/C head unit, but still blows hot air? Even without lights does the Fan Up/Down do anything?

I do not see a diag for your exact problem(s) in the FSM but use this chart to start tracking wiring until someone who has had this problem chimes in. Note the sources of power starting from the heavy boxes top left:


 

·
Registered
Joined
·
580 Posts
Discussion Starter #3
The display and all the controls are completely dead. The fan definitely isn't running on high. Not sure if it's on low or if hot air is just seeping through the vents. It is enough where I have to close the vests on a warm day.

Before it just went completely dead, after starting the car, the climate control didn't work for about 2 minutes, then came on fine. Worked about another week or less, then went dead... so far for good.
 

·
Registered
Joined
·
8,197 Posts
If your dash is already otherwise cracked then feel free to pound it hard to wake up the common "dead dash lights". Otherwise sounds like a power open (probably not a fuse since you won't get a, "didn't work for about 2 minutes, then came on fine") Outside of checking with VOM you might pull the center dash apart to reseat the A/C head plug before starting to replace parts from the JY. google and forum Search usually bring up a batch of similar descriptions as yours. Just some thoughts.


EDIT: HTH
 

·
Registered
Joined
·
8,197 Posts
Mike,

4 months. Are you good, or still a glitch? If fixed = share eh.
 

·
Registered
Joined
·
580 Posts
Discussion Starter #6
The car is in Winter storage right now but before putting it away in December, it worked 90% of the time without me having to dig in to anything. So I still don’t know the issue for sure...
 

·
Registered
Joined
·
8,197 Posts
Just a thought to get it out and wring it out a few times to see what additional permutations of failures you can collect based on really cold outside temperature. Anything additional to increase the symptoms bank.....
 
1 - 7 of 7 Posts
Top