Chevy Impala SS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
Hey guys somthing weird happens today. Drove home from work cruising stopped to by gas and coolant was leaking out from the cap, never over heated first time it's done it. Got home and it did it again but not as much any ideas? Bad cap not holding pressure ?
 

·
Registered
Joined
·
46 Posts
Discussion Starter #2
Replaced cap topped off coolant let it idle turned off the car and it pushed the water out. Water pump and stat was replaced about 2-3k ago and radiator was replaced 6 months ago
 

·
Registered
Joined
·
46 Posts
Discussion Starter #3
Also noticed the thermostat housing is slightly leaking Think it may have sucked enough air over time to cause the water to boil/push out? Sorry guys I can figure out and build,fabrication however cooling and a/c I'm lost beyond the very basics
 

·
Registered
Joined
·
3,015 Posts
You say "topped off the coolant". There is a mark on the side of the tank about half way - that is the fill to mark.

Rent a pressure tester from AutoZone (free) - also you can test the cap with it.


That is a reservoir, not expansion tank.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #5
Any reason why all the sudden it might happen now? Three times in a row? And the third time after topping off the tank and a new cap?
 

·
Registered
Joined
·
932 Posts
It will overflow if overfilled. I know! Bleed it well and make sure the T-stat housing seals well. Any leak will cause the system not to pressurize and overheat.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #7
So if I'm understanding this correctly. With the housing weeping out water after it cools down,sitting over night,the air that gets sucked in will cause the system to push out the water cause it won't pressurize ? What's odd is it's not over heating in fact it runs at about 1/4 hash mark or a tick less . Didn't do it this morning but it did it again tonight after the drive home. The ambient air temp was a little hotter and just from a few stop and goes the gauge went up to between 1/4 and 1/2 gauge. It didn't push out much maybe less then 12oz, ordered a new t stat housing and o ring gasket nobody seems to stock a 160deg t stat anymore previous owner put the hyper tech program in it and I thought I remember reading somthing about they recommend a 160 over the 180 sorry not trying to seem stupid I just don't understand cooling systems beyond the obvious stuff
 
1 - 7 of 7 Posts
Top