Chevy Impala SS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
When I bought my 94 impala i noticed the cooling fans are always running even when the car is cold and a/c is off. So I looked at the fuse box under the hood and each fan relay has awire attached to pin 85 and are grounded to the frame. When i take off the wires the fans do not work. Can anyone help me on this?
 

·
Premium Member
Joined
·
8,383 Posts
Sounds like somebody didn't want to troubleshoot it any more and gave you something to deal with.

The PCM will turn on the primary fan at a certain temperature via grounding the relays or relay for that fan, with a wire hooked direct to ground from the relay for the turn on it would look like something is haywire from the PCM to the relay. One check that can be done for this, is there is an ECT sensor on the front of the water pump, if this connector is unplugged it will turn on the fans within 30 seconds, if this doesn't work the wiring from the PCM to the Fan Relays should be checked.

With the jumper off and the A/C on, does the secondary fan come on? if not same scenario.

Another common thing on our cars is the relay bases and wiring melts and cause this problem. Gary @ innovative wiring sells a wiring kit to fix this by going around the fuse box, and it maybe and option for you with this. so check this first, you will have to take up the underhood electrical center (the black box) and look at the contacts and see if this maybe the problem.

That is all that I can offer for you, hope this helps. Attached is the diagram of the system
 

Attachments

·
Registered
Joined
·
3,505 Posts
"With the jumper off and the A/C on, does the secondary fan come on?"

FYI, the primary fan is on the passenger side and is the one that comes on with the A/C.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
Ok i finally had a chance to check the fans. I took off the jumpers and the primary fan (passenger)comes on when i turn the a/c on. And both fans turn on when i disconnect the sensor on the water pump.

So at what temp should the fan come on normally. I let the car heat up till about half way on the gauge but the fans doent turn on.
 
1 - 5 of 5 Posts
Top