Chevy Impala SS Forum banner
1 - 3 of 3 Posts
G

·
Discussion Starter · #1 ·
A few weeks ago, I did CompCamsProMagnum 1.6 RR's & CM 614 springs, pushrods, & seals in Wagon. Put in new GM plugs (thru-wheelwells after removing splash aprons) & M1 5-40 oil. Did it all at friend's shop with him on a Sunday after opening things up Sat eve. Set lash at 1/2 turn. Sounds quiet, feels good, but I haven't driven car since done & want to give it some break-in before stomping on it. Did it 'cause I had some valve float before WOT shifts w/72K.
 
G

·
Discussion Starter · #2 ·
Let us know how it turned out once you get some miles on it. This mod is on my list of "to do's". I am curious if you notice any HP gains. Also, did you keep the stock valve covers? Any clearance problems? I am glad to hear they don't make too much noise.
 
G

·
Discussion Starter · #3 ·
Kept stock valve covers - all you need to clearance them is a pair of pliers to squeeze the breather baffle a bit & some snips to cut away part of the bridges inside (you'll see what, exactly when you try to fit them, & to clearance them will take 5 min)

Still haven't put more than 3-4 miles on car, it feels great, but I need to give it some hwy running for 250-500 miles before I'll be ready to stand on the gas. Used MI 5-40 oil & when you are ready to do mod, PM me & I'll e-mail you or send you some really good "cliff-notes" I synthesized from posts here & you should visit Comp-cams & Crane-cams websites for install instructions & tips, Frank.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top