Chevy Impala SS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter #1
My digital dash isn't coming on. The idiot lights work, just the part where the speedometer and miles are isn't coming on. I cranked up the dimmer but it still isn't coming up. I've done a little bit of Googling and I'm thinking I'll start with the Twilight Sentinel. I turned that off, but the speedo still didn't come on. I think on one of the pages I Googled they said the yellow wire sends power to the digital speedo. I'll have to read my service manuals. Anyone have any suggestions? If I can't figure it out from the TLS I guess I'll pull the dash and check for corroded connectors or loose wires. The car been sitting in my yard for 2 years and I removed the interior. Didn't smell like mice so I don' think rodents got into it to chew anything up

paul
 

·
Registered
Joined
·
132 Posts
Discussion Starter #2
Found this on layitlow.com

Here's what happens to mine:

When it's sunny outside and the lights are off, the digital display should be bright. But when it's dark and the lights are on, the digital display is supposed to dim a bit, while all the other dash lights are illuminated. Well on mine, it's always dim, and the rest of the lights behind the climate control, etc. are out, as if I turned the dimmer switch all the way down. If I punch the Twilight Sentinel, they come back up.

I pulled the Twilight Sentinel out and checked the connection. There is a yellow wire in there that controls the dimming feature, and that was/is loose. I tightened it up and it was great for a while, but now it's shaken loose again and I have the damn dim dash. It's a PITA to see during the day, but it's not like the speedo went completely black. That would be a different wire.
 

·
Registered
Joined
·
8,056 Posts
Perhaps a different issue, but my last FWB every few months took to the whole dash going blank. I recall it being an infrequently known problem with our model, - solved in my case by one or two sharp blows to the top. I would not recommend this with a good top, but mine was severely cracked and covered by dash mat.
 

·
Registered
Joined
·
132 Posts
Discussion Starter #5
Ok,

I sent the digital dash off to get repaired. Now the speedometer, fuel, and mileage come on but none of the idiot lights are coming on. I checked the circuit that supplies power and ground to the idiot lights and both are good. Only thing I can think of is that the connector isn't making good contact when I mount the cluster. I'll check the cluster circuit for each bulb and the bulbs tomorrow morning.

Any other suggestions guys? Hopefully someone out there has seen this before.
 
1 - 5 of 5 Posts
Top