Chevy Impala SS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 · (Edited)
So say I'm removing the Optispark in my 95 Caprice and one of those stupid tabs that secures the plastic connectors in place breaks....what is the best way to remedy the lack of that plastic locking tab?

Can't find that part at any of the local places unless I'm looking for the wrong thing. I'm talking about the connector that hooks into the Optispark on top/left (as you are facing it) of the Optispark.

If there is a better forum for this question, please let me know and/or feel free to move it for me.
 

·
Registered
Joined
·
85 Posts
Discussion Starter · #3 ·
Thanks....have one on the way.
 

·
Registered
Joined
·
3,096 Posts
FWIW - the locking tab on my opti connector (opti end) was missing when I bought my wagon in 2002. I have never replaced it because there is still a very tight seal - a good GM design. I also keep that area clean. I am all for maintenance and I don't usually cut corners and I like upgrades - note I have 3 of Gary's cables and consider proper electrical condition a very high priority. But in some cases, those pesky tabs just aren't necessary, or lets say - no big deal if they are missing. Nothing wrong with buying a new harness, but if $$ is tight and it still works and seals well, put your effort to better use. Lots of skilled mechanics routinely (intentionally or not) break them and most customers and their cars never know it. Note - all this is conditional on harness and connectors being in good shape - I am not suggesting tabs are not a good thing.
 
1 - 4 of 4 Posts
Top