Chevy Impala SS Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 1992 chevy caprice it has a 350 TBI in it. when driving the car it runs fine but at idle it revs up and down till it stalls. After it stalls it starts right back up with no problem but still revs up and down at idle. Can anyone give me an idea of what it possibly is?
 

·
Registered
Joined
·
1,040 Posts
Check your IAC valve
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Thank you for the ideas. the IAC valve was already replaced but please if you have any other ideas let me know.
 

·
Registered
Joined
·
262 Posts
I had this same issue a few months ago. My LT1 would start revving on it's own at idle in park and in gear.

I changed my IAC valve and cleaned every sensor i could find. It ended up being my Optispark screwing up, causing electrical surges which was causing the raising idle.
 

·
Registered
Joined
·
1,040 Posts
Unsure of this, but did you look at the injector spray patterns? do they look even compared to each other? also check ur vac. lines for cracks and pcv valve.
 

·
Registered
Joined
·
68 Posts
Have no idea about the TBI, but i had the same problem with my LT1 and it turned out to be the TPS sensor, changed it and all back to normal.
 

·
Registered
Joined
·
3,913 Posts
With TBI, the ECT sensor in the water jacket on top of the intake manifold goes out of range. It misreports engine coolant temperature and therefore the improper amount of IAC steps and a/f ratio are commanded. Viola' poor fuel economy and stalling.

Also clean the grounds on the intake manifold.

Oh yeah it might be an opti:D


J/K no opti on tbi.

Chris
 

·
Registered
Joined
·
11,473 Posts
This symptom is caused by the hose between the fuel pump and the outgoing pipeing. It has a crack in it. I have had it happen to me twice. The only way you can check it is to check the fuel pressure. It is actually easier to remove the fuel tank and visually inspect the part, then to go throught the gyrations of getting something to splice into the fuel line to check the pressure. I could not even get a garage to check the fuel pressure. This has happened to 2 or 3 people I know as well. Use a hose designed to be submerged continuously in fuel, and use stainless screw clamps.

I changed every sensor, wire, and other possible part to no avail. When I was done the only thing left was the fuel system.
 

·
Registered
Joined
·
511 Posts
Was the problem occurring BEFORE you replaced the IAC?
There is a procedure for "setting" the IAC. Was it followed?
 

·
Registered
Joined
·
731 Posts
+1 with Fred, my 92 9c1 had the same problem, at first it wouldn't stall but would do the constant sharp up and down idle.

It also interestingly enough would not do a "180" U-turn at WOT either, it would litteraly die for a second until the g's were gone and then would take off again.

Towards the end it got to stalling, and I eventually sold it after acquiring the 95. The next owner down the road said that the rubber hose in the fuel tank had a bad split in it causing the issues.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #13 ·
earlier tonight i changed the ECT sensor and it is still reving up and down at idle and i checked all the grounds on the intake and they are good too next weekend i will check the fuel system but let me know if you have any other ideas. thank you all for your help.
 

·
Registered
Joined
·
488 Posts
A bad oxygen sensor will also cause the motor to rev up and down. They also make a tool that replaces your fuel filter that you attach a fuel pressure tester to.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #17 ·
finally i have finished all the ideas everyone gave me but the car is still reving up and down at idle. i didn't mention it in any of the other posts but when i first start the car it runs fine it starts the reving up and down after it warms up. not sure if that makes a difference on what i could be or not.
 

·
Registered
Joined
·
11,473 Posts
finally i have finished all the ideas everyone gave me but the car is still reving up and down at idle. i didn't mention it in any of the other posts but when i first start the car it runs fine it starts the reving up and down after it warms up. not sure if that makes a difference on what i could be or not.
So, what you are saying is that it only has the symptom in closed loop operation, correct? What have you actually done to the car. PLease list the checks/replacements/cleanings you have performed so that they can be eliminated.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #19 ·
replaced: -IAC sensor
-Air temp sensor
-O2 sensor
-Map sensor
-TPS
-engine coolant tempeture sensor
-Checked engine grounds
-fuel injecters are spraying evenly and freely
-spark plugs and wires(after they were replaced one wire ended up touching the manifold and burned through i only replaced that wire)
-checked rubber fuel lines for cracks and both have been replaced along with the fuel pump
- the car also has a hesitation
 

·
Registered
Joined
·
116 Posts
Make sure you don't have any vacuum leaks. Might not be your issue but with all my mods, I had a heck of a time getting mine to idle right. After replacing all sensors and having a "custom" chip burned (WASTE of MONEY) finally broke bad and bought the flash EBL from dynamicefi.com. His base tune was spot on and idle issue gone.

Check all basic items first as posted by Fred,and let us know what you find, seems to a common problem on TBI cars. Steve
 
1 - 20 of 25 Posts
Top