Chevy Impala SS Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6,853 Posts
Resistor on heater box. It's fairly common failure point....
 

·
Banned
Joined
·
3,437 Posts
What could the cause of the a/c fan speed not being able to adjust from high to med or low
last year I lost one speed . all the other speeds worked. dropped out the wire resistor assy and as was mentioned the resistor connection was rusted off..

as a temp fix cleaned up the rust and put a dab of solder on it.[summer]
ordered from rock auto the cheapest price OEM made in usa, 1995 vintage .. exact same resistor assy except NO rust..

drop the blower motor clean that out also ......
 

·
Registered
Joined
·
11,219 Posts
You can put a coating of silicone on the base of the wires to keep water away from them, and the rust will not form.
 

·
Banned
Joined
·
3,437 Posts
You can put a coating of silicone on the base of the wires to keep water away from them, and the rust will not form.
on my resistor failure the connections were like new , the actual wire resistor rusted .. those resistors get hot ...

down in Florida connections are a problem with all the moisture ..
I never had corroded connections in the vehicle interior ..possible the air box in your area gets over loaded with the high humility creating puddles of water draining down into the resistor connector ..
 

·
Registered
Joined
·
11,219 Posts
on my resistor failure the connections were like new , the actual wire resistor rusted .. those resistors get hot ...

down in Florida connections are a problem with all the moisture ..
I never had corroded connections in the vehicle interior ..possible the air box in your area gets over loaded with the high humility creating puddles of water draining down into the resistor connector ..
All of the connection areas on all of the resistor packs I have seen, have all been rusted. It did not matter if it was a northern or southern car, and both come into the yards here. I have not searched them out, because I have the electronic module on my cars, so I can not vouch for all of them. I do not pull them for that reason.
 

·
Banned
Joined
·
3,437 Posts
All of the connection areas on all of the resistor packs I have seen, have all been rusted. It did not matter if it was a northern or southern car, and both come into the yards here. I have not searched them out, because I have the electronic module on my cars, so I can not vouch for all of them. I do not pull them for that reason.
I am now in your area the other day dewpoint 77deg F .. my ride was covered with water ..

up in the cold north 77F dewpoint is maybe once a year so with ac on , a ton of water all over the air box .. had a big puddle under my truck were I parked it ..
I certainly believe it in your area ...have to coat the internal connectors with silicone grease in around the air box..
 
1 - 9 of 9 Posts
Top