Chevy Impala SS Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
976 Posts
Discussion Starter · #1 ·
This is a list of the issues i have with the car i just bought and am hoping you guys could help out...
When i first start the car it lopes for about 2-5 sec then smooths right out, '93 - 5.7
My rear most lnterior lights turn on by themselfs, i hit the switch they turn off but then if i hit the grab handle they light back up. Could it be due to the dash saying "gate ajar" even when the door is shut?
How to i fix the "gate ajar" problem?
Rear passenger window rolls down but falls crooked and drivers rear does nothing?
That is all i can think of that is wrong with it so far (fingers crossed) Thanks for any help and suggestions
 

·
Registered
Joined
·
45 Posts
the left rear window is very common and happend to my wagon and my bros old sedan it just needs this little plastic piece that holds the glass to the regulator. my wagon doesnt have a "gate ajar" but only a "door ajar" but i also have a problem with the phantom lights lol that just come on randomly... i thought it was just me
 

·
Registered
Joined
·
11,501 Posts
The switches can go bad. The gate ajar light means that your gate is not shut tight enough, or the switch inside the gate is in need of adjustment. You really need an FSM to work on the gate. The lights will come on if the gate is not shut properly. The switches on the grab handles work in different ways on each side. I haven't used mine is so long, I forget exactly which one does what. You may also have a ground wire which is near metal under the grab handle, and when you touch the handle it may make contact. If you need a set of switches, I may be able to get a set. As for the gate adjustment part, you are on your own.
 

·
Registered
Joined
·
1,176 Posts
The rear lights are supposed to come on when the gate is ajar.

The passenger rear crooked window is a common problem. The fix is in the Qalo'ss manual, which has its own sticky thread at the top of one of the forums.
 

·
Registered
Joined
·
976 Posts
Discussion Starter · #6 ·
Thanks, ill look for the switch on the tail gate. I went through it today and took dam near 3 hours just to clean the smoke film off every window to where they are spotless now. Also went through and replaced all the burnt bulbs, put in led tag lights and lubed all the hinges. Even threw on a coat of wax. Im trying not to get too carried away so i can get back on the caprice but its soo hard.
 

·
Registered
Joined
·
11,501 Posts
The loping issue could be as simple as the PCV valve, or if it gets worse, the rubber hose between the fuel pump and the sending unit piping (I had one split). It does not sound like an electrical, EGR or sensor problem.
 
1 - 8 of 8 Posts
Top