Chevy Impala SS Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
346 Posts
Discussion Starter · #1 · (Edited)
crazy, just changed pcv valves, wires, and plugs, and coil now I go to start the car and it barely runs and when I press the gas it cuts off. check fuel pressure and it reads 0. I can start the car but It will barely run for a few seconds. if I press down on the fuel valve, gas squirts out. I can't tell if I hear the fuel pump priming, but I don't think it is. where should I start. fuel filter was changed less than 500 miles ago. fuel pump is 5kish miles old.
95 caprice lt1
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #2 ·
I changed the plugs because they fouled out.
 

·
Registered
Joined
·
1,040 Posts
????what year, car, motor??
 

·
Registered
Joined
·
9,682 Posts
Did you make sure there is enough gas in it? The fuel gauges in these cars are notorious for being inaccurate....

Did you replace the wiring inside the tank when you did the fuel pump? If not, you probably have a cooked connector. Have someone turn the key on while you listen at the gas tank. If you don't hear anything, try constantly beating on the bottom of the tank with your fist while someone tries to start it. A lot of time you can temporarily beat it back to life. If this works, then you'll have to go inside the tank again...
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #6 ·
thanks, will look over things when I get home.
 

·
Registered
Joined
·
734 Posts
x2 on Goldmaster Did you make sure there is enough gas in it my car did the same thing come to find out after takin the pump down wasnt enough gas in it.
 

·
Registered
Joined
·
6,443 Posts
Where are Lt1 Fuel pump relay at............ could be bad but do the trunk thing. Ive heard about problems like that before.
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #9 ·
relay is by driver side kick panel I believe
 

·
Registered
Joined
·
9,682 Posts
FP relay is located in the under hood fuse/relay box on passenger fender well. Location in the box should be labeled on the underside of the lid.
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #11 ·
2 of 2 goldie, gauge had me fooled, filled her up and primed it up to 40 and she is back in action, thanks, six pack in mail?
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #12 ·
could have swore I filled up the tank before parking it a year ago.
 

·
Registered
Joined
·
9,682 Posts
2 of 2 goldie, gauge had me fooled, filled her up and primed it up to 40 and she is back in action, thanks, six pack in mail?
Lol no problem man. Glad it was an easy fix.


Who knows, maybe you did have a full tank, but someone siphoned your gas while the car was sitting. It's been known to happen around here anyway....
 
1 - 13 of 13 Posts
Top