Chevy Impala SS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1 (Edited)
still trying to find out what my issue is with intake backfire

yesterday i tested fuel pressure

just key not running 22psi

car idling 35psi
revving engine 43psi

idle but vac disconnected 45psi

car off and left off for 5min 36psi


items changed so far
new plugs/wire
cap and rotor
fpr new
 

·
Registered
Joined
·
1,144 Posts
still trying to find out what my issue is with intake backfire

yesterday i tested fuel pressure

junk key no run 22psi

car idling 35psi
revving engine 43psi

idle but vac disconnected 45psi

car off and left off for 5min 36psi


items changed so far
new plugs/wire
cap and rotor
fpr new
That's what most of us get with old pumps. 22 psi is low, but check the battery voltage. When it is 12.6 V it should be around 40 psi. If it i still 22 psi, your wiring or fuel pump is not good.
 

·
Registered
Joined
·
6,739 Posts
My fuel systems holds zero pressure,and has for many years. Doesn't affect the cars running operation even a little bit.
 

·
Registered
Joined
·
8,455 Posts
when you turn key on/engine off the FP gauge should immediately snap up to around 42-44 PSI for a few seconds (pump is priming) and then drop to around 36-38 (pump stops priming)

22 psi suggests the pump is weak or fuel filter is clogged...or possible high resistance in wiring connections to/in pump assembly knocking VDC down to low volts

The RA link you posted is the pump sender assembly....does not look like the pump itself is in it...unless I am missing something
 
1 - 7 of 7 Posts
Top